Running out of gears & Erg mode not working

Hi, I’m using Zwift in Windows 8.1 , and Elite Qubo Digital B+ smart trainer.
I have 2 issues, please help me to resolve them :

  1. On Zwift races/group ride/free ride, I’m running out of gears. Even at 50 × 11 , I spin like 120rpm easy & still can’t produce more than 250W (my FTP is 2.84 W/kg i.e. 185W ). It seems like the trainer isn’t changing resistance according to the terrain, whether flats or climbs.

  2. In workout mode : The erg mode isn’t working. I make sure that it’s activated, but during workout, the trainer doesn’t adjust the resistance to match power output.
    I’ve used erg mode on Sufferfest before (same setup), and it’s working very well on it.

Meantime, I also used Elite mobile app to check whether the trainer is receiving and giving out signals. The trainer’s fine.

I have tried using both ANT+ and Bluetooth (bridge via Zwift companion). Zwift connects to the trainer as “Controllable”.
I’ve also tried reinstalling Zwift and updating it to latest version.

Any help is appreciated. TIA.

Is trainer difficulty set to 100%?

Although, Even at zero you should be getting more resistance than what you are describing.

How do you know erg is on. I always get confused with how zwift displays erg on / erg off - I can never remember if the button saying erg on means erg is on, or if it means press this to turn erg on.

Final suggestion, is the trainer still paired with another app (running in the background or asleep) which is messing with the trainer?

1 Like

Sounds like you need to re-calibrate your trainer. Here is a short thread about people having some problems with that particular trainer with a possible solution: Calibrate Elite Digital Smart B+ turbo

1 Like

Hi Ben, the trainer difficulty is at 50%. Should I increase it to 100%? But I heard that it’ll affect only how I feel on climbs.

I toggle Erg mode on/off via Zwift companion app.

Nope, I shut down all background apps.

Hello Fez, thanks! Will check that thread.

Update : Solved .

Remapped and Resetting the trainer worked for me. The thread link provided by Fez is useful. Thanks!

1 Like