Calibrate Elite Digital Smart B+ turbo

Hi there,

I calibrated my Elite Qubo Digital Smart B+ turbo trainer last night via the Elite myEtraining app (no wrench on the Zwift pairing page).

Since calibration, my watts output on Zwift is crazy high - my FTP is 166 but Zwift is now telling me I’m pushing out 1,500+ watts!!

The turbo feels OK when I’m pedalling so it seems more of a configuration rather than a hardware issue. Any ideas?

Cheers,

I am having a similar issue with the power being WAY too high!

I’m using the Elite Novo Smart (which is essentially the Qubo Digital Smart B+ but with a different frame) with an iPad over Bluetooth connection. I’ve also use a MacBook Pro running macOS Catalina with Bluetooth. Zwift version is 1.0.49822

The watts have gone crazy high just like you’ve said and can be quite random.

I’ve even re-mapped the trainer using the myETraining Elite app and written in the original factory P1, P2, P3 values however I’m still getting very high readings of power. I’ve tried adjusting these P values and it still causes havoc.

I’m trying an Ant+ dongle to see if it makes a difference but if anyone out there can help, it’d be much appreciated!

Hi Paul,

I seem to have managed to fix the issue on my end.

There’s a couple of things that I did as well as a couple of tips that I will share.

Firstly, I re-mapped my trainer through the myEtraining app over Bluetooth from my iPhone. Now, one thing to remember is that the numbers that show in the pop-up for the P values aren’t actually what’s in the trainer. They are the default values.

If you want to view/check the P values, either before or after you’ve mapped it, then if you click on the email address - myetraining@elite-it.com at the bottom of parameters page, it will show you. See the pic attached -

Now, once you’ve done this and to check it feels as it should, again in the myEtraining app, go to Trainings > Level Mode which is free and you don’t need a subscription. You can then view your stats there - speed, watts, etc.

If you click the sliders at the bottom, you’ll see that you’ll be able have a play with 16 different resistance settings by hitting the + & - buttons in the bottom right hand corner.

Once I’d done this, it seemed to ‘reset’ my trainer and everything worked as it should. I’m not sure why, but it worked.

I still need to verify it against an actual power meter, but it’s far more realistic now!

Here’s some other links for info:-

One thing to note is that I would advise not having any other devices in the vicinity just in case they interfere.

Good luck and let me know if you have any questions!

Sandy

1 Like

Thanks for this info.

I had instructions from Elite for what I think was a factory reset which seems to have made things better. It’s difficult to tell without another power meter to compare it to but at least it’s in the right range now.

Here’s the instructions they sent:
Download the app NRF Connect app on your smartphone:
if Android: https://play.google.com/store/apps/details?id=no.nordicsemi.android.mcp&hl=it
if iOS: https://apps.apple.com/it/app/nrf-connect/id1054362403

Then follow the indication at this link: https://youtu.be/06PjSmtSAoc

At the end check if you have still problems.

So at the moment it’s working ok without that feeling that it’s 100% right.

They are also sending me a replacement electronic board so I’ll see how that goes.