No resistance / power too high on Elite Novo Smart

I have just set up a new elite novo smart digital b+.

Just stated on Zwift but my power seems way too high, feels like there is no resistance when I pedal normally I have 500-600 watts easily.

It also goes up and down 500-70-300-500-70.

I have tightened the unit. Using a road bike 27.5” wheels, 32mm tires at 100psi.

I am using Bluetooth to iPhone XR or MacBook.

I don’t have a power meter to calibrate.

Any suggestions?

Hi Amy,

I am having a similar issue with the power being WAY too high!

I’m using the Elite Novo Smart with an iPad over Bluetooth connection. I’ve also use a MacBook Pro running macOS Catalina with Bluetooth. Zwift version is 1.0.49822

The watts go up and down just like you’ve said and can be quite random. I could be pedalling at low level cadance and gears and it’ll be okay for a few seconds (eg. 80-90w) and then after a few seconds go quickly up to around 300w and then will get stuck at say 511w.

I’ve even re-mapped the trainer using the myETraining Elite app and written in the original factory P1, P2, P3 values however I’m still getting random readings of power. I’ve tried adjusting these P values and it still causes havoc.

I’ll be trying an Ant+ dongle to see if it makes a difference but if anyone out there can help, it’d be much appreciated!

I seem to have managed to fix the issue on my end.

There’s a couple of things that I did as well as a couple of tips that I will share.

Firstly, I re-mapped my trainer through the myEtraining app over Bluetooth from my iPhone. Now, one thing to remember is that the numbers that show in the pop-up for the P values aren’t actually what’s in the trainer. They are the default values.

If you want to view/check the P values, either before or after you’ve mapped it, then if you click on the email address - at the bottom of parameters page, it will show you. See the pic attached -

Now, once you’ve done this and to check it feels as it should, again in the myEtraining app, go to Trainings > Level Mode which is free and you don’t need a subscription. You can then view your stats there - speed, watts, etc.

If you click the sliders at the bottom, you’ll see that you’ll be able have a play with 16 different resistance settings by hitting the + & - buttons in the bottom right hand corner.

Once I’d done this, it seemed to ‘reset’ my trainer and everything worked as it should. I’m not sure why, but it worked.

I still need to verify it against an actual power meter, but it’s far more realistic now!

Here’s some other links for info:-

One thing to note is that I would advise not having any other devices in the vicinity just in case they interfere.

Good luck and let me know if you have any questions!


I’ve been running into similar issues occasionally using the Novo Smart, using PC with Windows 10.

Using info above I was able to get into the MyETraining app and after finally picking the correct trainer could see recalibration options etc. Took me a while to find the stored P values - with latest version of the App you need to scroll the top ribbon over to the Contact Us selection then you see similar info as posted above.

Reloaded P values and did a manual run taking the resistance up and down which seemed to help for my next ride though I’m not sure if the power meter is reading high now :frowning :confused: as I seem to be pushing more Watts but have also played with trainer difficulty again so I have bit more resistance on descents.

Sadly tonight the issue returned - set off on a group ride and resistance not kicking in so was spinning almost I too gear with tyre howling away on the trainer. Couldn’t seem to improve it pulling the power on the trainer or picking different pairing options. Also seemed to notice the connection LEDs on trainer both flashing.

Been trying with trainer paired through ANT+ and picking FE-C options, gets confusing with maybe 3 or 4 different connections to pick from now but can’t find one which seems to eliminate the problem.

Ran better later on after restarting everything and doing a decent test ride before joining group session.

Guys have these issues settled for you? Mine seems fine in ‘controllable’ mode but way down on residence should I not pair it and attempt to ride simply on power.
I would stick to controllable mode but am nervous about that for racing or TT. I know that you can adjust resistance within zwift from the menu but this option doesn’t exist when riding without ERG? Any thoughts? Thanks in advance.

Following this thread as My Elite Novo Smart has just started acting the same. Minimal resistance yet ridiculous wattage going uphill and my perceived effort and HR is barely raised. So unless my fitness has miraculously improved overnight… something is awry. I tried the fix above and the trainer seems to work fine and as expected on the elite app itself but something seems to have changed in the interaction with Zwift… any help appreciated!

My novo trainer has started to do exactly this this last week also watts are way too high up hills and low on flats also can’t feel resistance on it. Have you managed to sort yours yet? I contacted Zwift they told me to contact elite I tried what they suggested but still no luck!

Nope I’ve ended up having to buy a different trainer. The Elite is working fine with it’s own app so there is nothing wrong with it and it looks to be something to do with the integration with Zwift making it unusable, unless i want an really easy workout. So annoying though and there seems to be so many new topics on resistance issues across the board though so it sounds like there is something wider awry but getting no response from Zwift guys so far.


I reset my Bluetooth and also had the friendly team at FulGaz make sure the elite novo works with them.

Since then it’s working fine.

So I’ve switched to FulGaz!


1 Like