Runn sensor issues

Does anybody have the runn device for their treadmill? I have tried so many different ways to pair it. I just got it as a gift a few days ago I even tried adding bigger reflection stickers… I was able to calibrate it with the gym track app and the configure app. But it won’t calibrate with the zwift app. Every time I go to update the film where from the configure app because it says it needs one the device shuts off instantly when I say yes, update the firmware. if anybody has any suggestions that would be great before I throw $100 in the trash… i’m currently using my Garmin forerunner 945. It’s off a little bit but at least it’s something. Frustrating beyond frustrating.

I calibrate it with the configurz app and have no issues, just make sure you calibrate it the 3 times in a row before it says done. It will ask you to increase the speed from the 5mph then up, up again. Does Zwift in game see the RUNN as an option?

There are others on this forum who are able to troubleshoot Runn problems @10K.Every.Day.In.23 in particular. Don’t throw away your Runn until Stuart has had a chance to help out.

My Runn has been great and always connects but I don’t really know why. I pair it to Zwift on both IPad and Laptop.

You do not need to calibrate a Runn - even though they give you the option to.

Are you connecting via BLE or Ant+ ?

I’m sort of throwing something out there which I don’t fully understand but is your forerunner interfering with your Runn connection to Zwift?

If Runn works with ConfigureZ then you must have Runn and sensor strips set up correctly.

You probably have all this information but if not this link gives as much information on Runn as I have seen anywhere. It explains the LED which signify BLE or Ant+.


Just so I’m sue of what the issue having is.

Are you saying that when you are trying to update the Runn using Configurez app it is getting so far before quitting the app and you have to start the process again?

Hey Stuart,

So when I go up update the Runn sensor device with new firmware. I get the pop up that says you want to update now and I say yes and when I do that the Runn sensor device shut off as soon as I can yes and then the ConfigurEZ app starts searching for device again and I can’t turn on Runn sensor device for a few mins which is weird.

Hey Jason,

The Zwift app does recognize it but when I got to calibrate it with the in game calibration and go thru the steps it basically try’s then get error messages saying device disconnects. When I tired to run with it on zwift I can see that my treadmill speed is show but my person is walking so there is just something not connecting.

Why are you calibrating it in game after you calibrate it using Configurz?

I thought you had too because once I calibrated with configure app and tried to use it on zwift app it was way off. If I had treadmill speed 5 Zwift would show me running at 8.9 something crazy


Although I’m not ruling out a hardware issue with your RUNN I don’t think its faulty.

The calibration issue you are having with Configurez is potentially an issue with your phone. Certain phones do not work well with Configurez and in particular with the firmware update.
Samsung Galaxy S series can be a pain along with some of the older IPhones. I’ve not tried with the newer ones.

If you have access to another phone or tablet then try that. Very often the firmware update with get so far along then stop. You repeat the process and you’ll notice that the progress marker starts just about where it stopped. Sometimes you’ll get a bit further, sometimes not. It can take 20-30 attempts to complete the firmware update.
Like I say this can be entirely dependant on your phone/tablet. I’ve had it go straight through on a Galaxy A Series.

What is interesting is that it’s disconnecting in the Zwift calibration. That’s not normal. However try moving the Runn higher and lower in the cradle as getting the ideal position can be trial and error. Even put it on an angle, higher on one side.

With regards to calibrating it in Zwift, yes you do need to do this otherwise it’ll not report speed correctly as you’ve seen. The argument is that it will only then be displaying the belt speed of your treadmill is valid and whilst people will say that treadmills are well out from the actual speed - they aren’t. I regularly calibrate treadmills and ordinarily they are not far off.

They are adjustable via turning a little module on the circuit board but we’re not talking about that for you.
Depending on your treadmill you will see that the Zwift speed from your RUNN “bounces”. Say you set the treadmill at 7mph, you’ll see the speed flicking between 0.5mph below and above this. This is entirely down to your treadmill. The better the quality of motor, the less it’ll fluctuate. If you are running commercial grade then it’ll not be that bad.
Home treadmills it’ll certainly bounce.
It’ll also get better or worse as the treadmill warms up.

The bouncing will vary at different paces also. As will the accuracy. If you calibrate at 8mph then don’t expect it to be accurate at 5mph or 11mph.

In essence the RUNN was (is) a great solution for many. However if you want data accuracy its less so. I moved to an app (QZ DOMYOS) that reads my treadmill speed via BT and sends this to Zwift. I demoted the RUNN to being a cadence sensor only but have since bought some trainers that have this built in.

Give the above a try (different phone) and see how you get on. Also if it allows but I seem to think it forces you straight into a firmware update - navigate to the menu that allows you to reset the RUNN. They have a tendancy to go into a deep sleep and only this wakes them up.