Ramp test resistance fail

Experienced rider but new to Zwift and Kickr v5.

The ramp test never increases resistance during the ramps. ERG on. Have rebooted, restarted, checked firmware, read Zwift’s troubleshooting sheet etc etc.

I’ve tried it multiple times over a few days. No luck. BTW, resistance works fine on normal rides. No issues there.

Any thoughts?

Hi @Michael_Albert1, welcome to the forums.

What device are you using to run Zwift and how are you connecting? Bluetooth or ANT+?

1 Like

Using iPad with bluetooth.

As I mentioned above, works fine on normal rides, changes resistance on hills etc.

Is it possible to post a picture of your pairing screen? What is selected for controllable trainer?

1 Like

Trying to find out how to post a pic here.

have you tried any other workouts to see if they are controlling resistance?

Yes, they all work fine. Resistance changes on climbs as it should.

Just want to confirm you are talking about other workouts with ERG mode enabled, not free riding where the resistance only changes on hills and such.

Oops. Just talking about free rides.

Haven’t tried a structured workout with erg enabled yet. Only three rides in.

Guess I should try that.

I thought I needed my FTP number for those but haven’t looked closely.

Make sure you have ERG selected

It is selected. I’m positive.

You will need an FTP for the workouts. Every time you do a free ride, Zwift will grab your best 20min power figure from it, if you set one. Do a few more vigorous free rides, or… eventually, when you’re in the workouts selection pane, your FTP will be displayed in the bottom right corner of the workout you’re previewing (it’s adjustable from there also—you can override it and type in any number you want).

Sounds like a good idea. But I want to eventually get a proper FTP from the ramp test, but I can at least test ERG mode this way.

…or you can drag the FTP slider bar in the right side of Mike’s picture up or down to adjust the FTP setting.

Tried an FTP workout and the trainer DID change resistance based on the target call outs.

So it just doesn’t seem to work for the ramp test.

This might be by (bad) design: https://support.zwift.com/en_us/ftp-test-HypJnI_NH says somewhat ambiguously that ERG mode is disabled for the FTP test, which I guess makes sense for the straight 20-minute test, but I don’t really see what the point of disabling ERG mode for the ramp test would be.

It says to use ERG for the ramp test in other places.

So your logic is correct.