FTP test bug fail


(Sean Flynn) #1

Everything was working fine during the warmup period with ERG mode. The resistance responded as expected. But once I got to FTP test the wattage/resistance was stuck at 130 watts. I couldn’t increase through a higher cadence, through switching gears, or by using the manual resistance increase button in the Zwift mobile app. Very frustrating. This was with Wahoo kickr trainer.

i’ve done this previously with similar setup no never this problem before.


(Eric C. (Zwift HQ)) #2

Hi Sean,

I need a few bits of information:

  1. Were you ANT+ or Bluetooth?
  2. If ANT+, were you using FE-C or KICKR?
  3. Is your KICKR on the latest firmware?

I’ve seen reports of resistance dropping out completely but never one where it just maintains a steady resistance. This info will help us pinpoint what’s happening.

Thanks!


(Sean Flynn) #3

To clarify, the resistance would drop below 130 watts if I slowed cadence, but it would not go above 130. 

I use the Zwift iPad app, so the Kickr is connected via bluetooth. Looks like I was not on the latest Kickr firmware. I was on v3.2.51 at the time. Subsequently, I’ve updated to v3.3.53. 


(Rune Kvamme (c)) #4

same issue, did it work after update, (Mac and Wahoo kickr)


(Sean Flynn) #5

I don’t know. I have not tried again since updating the firmware.


(Sean Flynn) #6

Just tried again and still an issue. I wonder if only way to get to work is disable ERG mode and then manually adjust wattage and resistance through gear shifting?


(Jason K) #7

Disabling ERG mode for the entire workout would probably let you work through this, but the underlying issue is definitely a bug.

I’ve made an email support ticket for you from this thread, so keep an eye on your inbox for more updates. If anyone else is experiencing this, you can also submit a ticket. Thanks!


(Steve Noons) #8

Having the same problem with my Kickr 2, zwift did seem to reset my ftp to 100. I slide back to 210 and started workout in erg no problems until I hit the test phase, then couldn’t get wattage over 115 no matter what I did…

Did spindown test tried agin in both normal and erg mode, no difference I have the latest firmware on all my kit i.e. MacBook Pro and Kickr 2

 


(John Petzold) #9

Same thing happened to me!  How frustrating to prep and built to the FTP.  Please alert us when bug if fixed. 


(Gerrie Delport) #10

John, You should be able to do the FTP test with ERG mode turned off before you start.

 


(Douglas Young) #11

I also experienced something similar to this just now doing the FTP test. Also on the Wahoo Kickr 2. I was using my Quarq Dzero as the power source and and Kickr as the controllable trainer. The previous intervals in ERG mode worked fine however once I got to the FTP test phase the resistance wasn’t set high enough so even in my biggest gear 50x11 I wouldn’t push much over 250 watts.

To add I had had the current mission (training peaks workout thing on before I started the FTP test).

I then closed everything bluetooth related on my phone. Started again with the FTP test and skipped a few of the initial intervals as I didn’t want to do them again. I did 6 minutes easy watts just before the FTP test then when I got to the FTP test it worked!!

Could it be something to do with the current training peaks mission and the FTP test? As that seems to be the only thing that changed between the two attempts.


(Kris S (TacoXpress)) #12

Had the initial issue listed at the beginning of the thread happen to me today. Regardless of the gear I was in or how high my cadence was, the Kickr adjusted resistance so that I was always at or just below the target wattage. I sent a ticket in to Zwift tech support a little bit ago. Hoping to get an answer soon


(Jeppe Thomsen) #13

Hi, is there any update on this issue?

I have exactly the same problem with FTP test yesterday. I also have a wahoo kickr powertrainer (new version 3) and I’m connected bluetooth to Zwift by an iMac. Building up / warmup to the real FTP test was no problem - took about 43 minutes. But when FTP test starts watt resistance was stuck on maximum 105 watt regardless my gear switching or cadence speed.

to your information my settings in wahoo fitness app is:

ERG Mode Speed Simulation - off

Erg Mode Power Smoothing - on

Control w/ANT+ Power Meter - off

PLEASE HELP ME :slight_smile:


(Douglas Young) #14

Any update on this. Is it something that is being investigated?


(Jeppe Thomsen) #15

Update - I believe, that I’ve fixed the problem according to Zwift FTP test on Wahoo KICKR Powertrainer.

If you have experienced same problem, as I posted earlier, here is my fix!

Step by step!

First be sure to disconnect any paired sensors to Wahoo Fitness app or Wahoo Utility aps. Thereafter make sure these apps are closed.

Go to Zwift app - unpair and repair connection to KICKR Powertrainer, cadence and heart monitor etc.

Then I recommend to do a spindown in zwift.

Aften doing the above, I have completed two FTP test in Zwift without any problems :slight_smile:

Please tell me, if the above fix work for you.

 


(PAOLA MARTINEZ) #16

Hi Jeppe:

Did you used ERG mode after the spin down?

I am facing the same issue. Warmup period is perfect. Then the power drops to 75ws and stays there no matter what I do. I change gears and nothing.

 

I will try your proposed fix and let you know. But please let me know if you used erg mode.

 

Cheers


(Jeppe Thomsen) #17

Hi Paola,

yes, I believe I used ERG mode after spindown. If ERG mode is default setting, I`m sure my answer is “yes”.

In other terms - I did not change anything in settings to make FTP test work.

Good luck trying me fix - please let me know, if it work for you. I’m sure it will :slight_smile:

Best regards

Jeppe


(Nigel Jolley) #18

I am having the same problem. Kickr snap 2017, zwift on iPad, can’t get above 110w. Haven’t tried the work around above. Has anyone else? Does it work?


(Ian Munro) #19

Same fault as above. Erg works fine till the 20 minute section then resistance drops to zero.

Wasted afternoon not happy.


(A Zmansbr) #20

Having the same fault on FTP test (shorter) with Kickr 2017, Tickr and RPM cadence sensor using Erg mode on Mac OS.