“No Signal” in the pairing screen

Device 1: Android 11 tablet for Zwift.
Device 2: Android 10 smartphone for the Zwift Companion app.
Smart Traner: Elite Suito binds to device 1 via Bluetooth.

There is no signal 20 minutes after the start. Until then, it can be used without problems.

In this state, there is no signal even if I reconnect on the connection screen. I need to shut down Zwift completely once.

If restart the smart trainer in this state, I can measure the wattage for a moment, but there is no signal immediately. Or it doesn’t react at all.

If connect another application in this state, it works correctly, that is, the smart trainer side is sending data.

Once I’ve completely shut down Zwift, I’ll be able to use it again.

Until at least 2022/03/13, there was no problem with the exact same environment and configuration.

When I changed Device 1 to a Windows PC and connected via Companion App, this problem did not occur.

Do you know any workarounds?
Or in the case of Zwift for Android, is it not possible to use the bridge explicitly?

I’m “glad” other people are reporting these problems because I’ve had to abandon my use of the ZC bridge (Android smartphone) since it started giving me big problems on 28/02/2022. Again, like you, it had been working OK prior to this date on the exact-same set-up. Maybe it’s something specific between Zwift and Android that changed during the recent app updates?

Thanks mate.
After trying lots of things these steps worked for me.

I realized every time I connect my Tacx Flux S to the Tacx Training app on my phone I have the No Signal on my PC.
However, if I follow these steps it works fine again:

  • Unpair trainer in Zwift program (desktop version)
  • Unpair trainer on pc, laptop in Bluetooth settings on your pc, laptop
  • Pair trainer in Zwift (desktop version)

Also facing this issue on Windows 11 + Saris Hammer H3. Still on the trial and was hoping it would be a lot easier to get started, not sure I want to spend money on something I have to fight to get working (getting myself onto the trainer already requires enough willpower!). Wahoo RGT seems to work fine with the same setup.

Hi Dan.

Welcome to the forum.

How do you pair the trainer?

Hi Gerrie,

I pair using Bluetooth. As others have seen, it connects under Power, Cadence, and Controllable, but after a couple seconds “No Signal” shows up. Have tried power cycling the trainer and closing/reopening Zwift.

1 Like

Are you using the Laptop internal Bluetooth.

Did you check that it is not paired in the windows settings?

I had these ‘no signal’ errors when I first starting using zwift in 2020. The error went away for nearly two years, and now it’s back. Looks like an app update broke it again :angry: Using Huawei Honor 9 and Panobike cadence/speed sensor.

Had tried everything ( updating and reinstalling app, toggling Bluetooth and aeroplane mode, unpairing, new batteries, restarts…) until I tried this suggestion and worked for me first time - aeroplane mode on / start zwift / aeroplane mode off. Cheers!

Same issue for me.

Worked fine for years and now Apple TV intially connects then seconds later loses signal.

El suito
Apple TV 4k

Tried all suggestions. Nothing works.

Is someone going to pick this up in Zwift HQ?

Seems to be getting worse. The flight mode trick has stopped working, and took half an hour to pair yesterday. I spend more time trying to pair the sensors than I do using the app. This is getting very tedious, on the verge of cancelling my subscription and finding abother platform.

Hi Lee

Did you try turning off all electronic devices around you. I found some fans that make a mess of connecting.

I have a small desk fan on while I’m training, but that can’t be it. I have bluetooth speakers, HR monitors and other devices connected no problem at all. Panobike sensor + Zwift = garanteed issues.

Try turning all those devices off.

Yep, tried that. It’s a known issue in Zwift. Like most people I have many bluetooth devices connected simultaeneously, without a problem. The BT speaker isn’t used when I’m on Zwift, have tried turning HR monitor off when pairing Panobike sensor, makes no difference.

One other thing I thought of, remove the permissions for the Zwift app. Then when you get to the pairing screen Zwift will ask you permission select this time only.

1 Like

Hi - this issue has just started for me tonight, after 3 years of Zwifting. All hard/soft ware has worked fine until now. I’m on a new Macbook Air which has worked previously. Have tried connecting via the companion app too, which normally works, with no success. This thread is two years old, so has anyone identified the problem and found a fix?

I’ve tried a new Zwift install, but that doesn’t work.

Same for me, was working fine for weeks, now no signal anymore…

Tried on laptop and android…both having the issue.

Reconnected Bluetooth and also restarted tacx neo2… disappointing…

This works for me! Thanks!

1 Like