Native Apple silicon Support for M1 and M2 Macs Enabled [1.47] [September 2023]

@shooj Thanks for looking at this for me.

I nowadays seem to be stuck starting in windowed mode, whether or not I’ve enabled full screen in settings, and the full screen toggle via the menu or the globe-F shortcut does work.

However, this Game Mode popup doesn’t appear in macOS Sonoma, as I gather there is a technical difference in how full screen mode is working in this case. Here is Rouvy:

I am aware this is a beta OS (unsupported by Zwift) but Zwift is unlike most of the games I have in that this mode won’t work, and there haven’t been updates to those apps specifically to enable it. As part of the changes are to enhance Bluetooth, I think it would be worth someone taking a look at it who is currently working on forthcoming updates, to see why this does work for most game apps and not Zwift.

1 Like

Thanks for looping back to clarify that you’re stuck in windowed mode. We’re on it.


1 Like

Umm, no. After 3 years of waiting I think most of us just got tired of asking. Great that they finally got here, but kind of anticlimactic at this point. I use a lot of software and Zwift was (by a long shot) the only Intel app I had running until today.


Yeah, I’m wondering about this also. Zwift has never, from what I can tell, actually run in true full screen mode. I also use IndieVelo and as soon as I updated to Sonoma, it also started giving me the full screen notifications on start. In true full screen mode, when you move the cursor to the top of the screen, you don’t get the notification bar popping down, which seems to be a tell-tale sign that Zwift is not actually running full screen.


That’s the remaining “problem”

1 Like

Rollout of this feature is complete.

If you’re using a Mac with M1+ processor, please make sure you’re using the latest version of the Zwift launcher app. One of the launcher’s functions is to detect if your Mac runs on an Intel or Apple processor, and kick off the version of the main game app your machine will support. If you’re using an outdated launcher, it will kick off the Intel build.

Download the latest launcher + game apps here.


This. It’s been way too long. And now after all this time, native support comes, and there’s not even a bump in visual quality. That’s really the bummer. Yay shadows! Shadows should not have taken 3 YEARS!!!

1 Like

The whole “no shadows” thing was a red herring. They could have turned this on a long time ago, Rosetta or not. The Apple Silicon carrot was just used as a convenient excuse to not turn on shadows for M1/M2 in High profile… Anyway, I guess it’s all water under the bridge now. In terms of visual improvements, it’s not unexpected that the native support had no improvements. The change to “Metal API” that happened months ago was where any visual improvements would have happened.

1 Like

Definitely great to see MacOS running native - well done Zwift!

I’m hoping the iOS and iPadOS apps could get some attention next. I understand they’re already native, they just don’t seem to have access to the same level of detail and framerates their M-series Mac equivalents do.

The new iPhones run the latest console games from Resident Evil and Assassin’s Creed, and the iPad is getting M3 next year. Wish Zwift could support more than Basic at 30fps soon!


Definitely seeing significant improvement running Zwift on a Mac Mini M2 Pro. 4K resolution, high profile, pinned at 60fps (max screen resolution), also running OBS with a 4K webcam on the same machine.

1 Like

Based on this, I’m guessing they could absolutely put the M2 Pro machines at Ultra profile… hopefully this happens and we we can get the best possible experience.

1 Like

Folks, I’m running a MacAir with M1 chip and the 8core GPU. I believe this update is now supposed to support M1 natively, if so I have an issue and am wondering if anyone else is experiencing this… The issue occurs when the system is on plugged in and not on battery power. Within 4 min of riding the thermals shoot through the roof turning the laptop into a cooktop, the only way to fix this is to dummy down the laptop by changing the battery setting while connected to conserve power, essentially cutting its legs off. However if I do this the CPU and GPU run around 59 degrees C , instead of 100!! This occurs whether I’m in Ultra or 4k and 30 or 60 fps. It makes no difference ( I output to 4k capable TV through HDMI ) . SO QUESTION FOR ZWIFT HQ , Do you know why this is occurring if Zwift is now native??

Do you see the running application name as “ZwiftAppSilicon”? (If not, update the launcher) I’m running on a 10-core M1 Pro in a MacBook Pro and not seeing a problem, but my system has a cooling fan while yours does not…

Yes it does say ZwiftAppSilicon. And yes mo fan , but you would figure that if native it should not require treating it like it was unplugged in power save mode. Obviously this has game smoothness implications. Out of curiosity what are your thermals, plugged and unplugged in power save mode. Would be interested in the delta value… THANKS FOR YOUR RESPONSE!!

Sorry meant to say plugged BUT NOT USING POWERSAVE MODE

I merged your subthread to the M1 discussion.

See this bit from the first post upstream. Would this apply to you, by any chance?

I’ve manually edited the config file, and it’s extreme beyond the Ultra profile.
I get a crazy amount of details and extra rendered stuff - and the Mini M2 Pro isn’t hardly working :grinning:

I might actually pull it slightly back, since it renders so many trees that I have difficulties capturing a propper Yeti photo now :grin:


I tried this a while back before native support was finally rolled out, and certain worlds (Makuri and France especially) were getting some very weird freezes and glitches. What settings are you using? I may try again now that native support is real.

These are the only available settings for me so if plugged in I must choose “low power mode” otherwise the laptop cooks. I.e. If I choose “never” the laptop cpu/gpu rises to around 100 and turns orange meaning running way to hot. As an aside this the behaviour prior to the port to native so for me I really don’t see the improvement…

1 Like

These are from a ride today with the laptop plugged in.

First without Zwift running:

Without Zwift

Second, sitting at the home screen for 15 minutes. Fans are off here.

Home Screen

Third, after about 75 minutes of riding. Fans are on here.

End of Ride