My rider won’t move on Zwift!

Good observation @Ben_Brawn, the garmin speed sensor isn’t being detected. Does the trainer have a built in sensor?

Nah I just checked and this is actually how zwift shows what trainer you selected when you are using a speed sensor.

1 Like

Bingo so not a trainer issue. Hahha am quite speechless atm as i know what am pairing or doing but perhaps I’ve missed something . Will give all electrical units new battery life to see

2 Likes

I got my Ant+ to store, guy tested works real fine. When i got it back to plug into my laptop the above error message popped up.
The store guy concluded its also a zwift issue from the looks of things
Any further advice?

I think that error is due to your network speed.

1 Like

Looking back at Shooj’s message, he said the cadence sensor was new as of June 17th, maybe that is causing some interference with the Garmin speed sensor? Can you unpair the cadence sensor and remove the battery so it is not giving out a signal and then just try the speed sensor? At least that will rule out the possibility that the cadence sensor is causing the issue. Maybe Garmin and Bryton is a bad combination of sensors??

1 Like
  1. Batteries changed on all dongles
  2. Ant+ works and confirmed via seller in hardware test and retesting
  3. Removed Garmin sensor, bought a brand new Bryton sensor
  4. All Bryton sensors connected to Edge 1030 and Zwift
  5. Avatar finally moved however only on a Samsung phone so was zwifting holding onto my cell phone
  6. Tried repairing everything on my Surface pro 7 - NahDah. Refuses to pair
  7. Forgot to mention that i also removed the Ant+ and connected everything via Bluetooth on my Samsung phone

Any reasons why my surface pro won’t connect to any of the dongles?

It could be a system driver issue with the ANT+ dongle? They are usually plug and play. Have you tried without connecting to the Edge, turn that off and see if it works?

It works just fine. Now how do I get my zwift back on my surface pro helppp :pensive:

If its network speed i won’t be able to load it and run on mobile as my mobile as 0 data balance left. This is highly annoying :cry::scream::pensive:

First just try powering off and restarting your wifi router and modem, it might just need to reset. If that doesn’t work then try this:

What wifi signal are you connecting to, the 5g or the 2.4g? Depending on how far away your surface pro is from the wifi router, you might need to use the 2.4 signal. 5g has a smaller range. You can also try setting the channel on your wifi to 1, 2, or 3 rather than letting it auto-connect to a random channel.

1 Like

I have unpowered the wifi routers today before purchasing a new Bryton speed sensor
It did not work. Currently on 5Ghz. Will try to manually reformat the wifi configuration as suggested later. Thanks

@Emily_C
Regarding the Z113 error on a Windows machine, let’s try removing everything related to Zwift on the hard drive, then do a clean install.

  1. Use windows Explorer and search for “Zwift”. There will be several folders and a bunch of individual files. Delete all of them.
  2. Download the latest from zwift.com/download
  3. Install that.

Once it’s installed - it’s a good idea to power off the Garmin computer on your handlebars. It’s likely that it was stealing the signal from your sensors, and is why you had issues pairing your trainer / bike / speed sensors.

Also very important - only run the Zwift app on one device at a time. If you have multiple devices logged in to the same account, it creates all sorts of problems. Power off whatever device you’re not using at the moment to Zwift.

2 Likes

Thanks I have uninstalled everything for the 50th time. Patcher code error still present today

You guys shd look back at the patch notes and work done. Its obviously causing some isuse as have seen this across the thread from time to time. Why fix or patch when there has not been issues. My entire setup was fine and working just alright until your most recent upgrades. Really sad folks and I’ve wasted so much time back forth and driving around thinking it’s my Ant+ issue and buying a new speed sensor

@Emily_C
Being at HQ, I’m wondering if these network errors might be due to limitations on internet access in your country? Not sure why a fitness video game might be blocked, but who knows?

You sound tech capable. Have you tried using Zwift over a VPN?

Won’t there be security issues for my laptops run this over vpn? Is this a recommended option by zwift? I read that those in Germany has similar issues as well over the week. How would you suggest i run them over vpn safely?
I literally almost terminated my zwift account yesterday and upon fiddling around it worked on my Samsung android after reinstallation.
Questions:

  1. To connect zwift over laptop Ant+ required correct?
  2. To connect zwift via Macbooks or Ipads no Ant+ required?
  3. To connect zwift via Huawei media pad pro - not workable at all as I can’t even load zwift on tablet

Is there an equipment limitation?

Interestingly now even my rider won’t move on my android phone. Oh lord zwift. What’s even bizzare all of my sensors paired but rider refused to move still. I guess smart trainer is my way forward or outdoor

@Emily_C

The avatar not moving can also be caused by multiple computers logged in to the same account.
Please log out of all of your devices. Then log in from only one. Does that help?