Avatar not moving although trainer is connected

Hello, I am brand new to Zwift!

I have a Kickr Core A431. Every time I open the Zwift app and load in, the trainer connects via bluetooth as the power source and I see that the cadence and controllable also connect and all say Kickr Core A431. My problem is that when I choose a ride, no matter how hard I pedal, my avatar just won’t move.
Under the power source option in zwift, I click the wrench to perform a spindown test. This does not register any speed.

I’ve also downloaded the wahoo app. The trainer connects via bluetooth but whenever I try to perform a spindown test it will not register any speed.

Please help. I just got Zwift and I really want to ride!!

This sounds like a trainer communication issue. I would focus of getting your trainer to pair and work successfully with your Wahoo app first then I suspect Zwift will work.

One thing is to make sure that other Bluetooth devices, like a head unit, is not grabbing your BT signal. Turn off you head unit and any other device that might be paring with your trainer .

The trainer pairs with the Wahoo app. I just don’t understand why it won’t register any speed, watts, or anything when I try to ride. I don’t have any other bluetooth devices connected to the trainer.

If you can’t even get it working with the Wahoo app, then it sounds like time to get in touch with Wahoo support.

I went through similar issues with my Wahoo Kickr Snap. The folks here were great in helping diagnose and kill the problem by doing lots of tests. See the thread entitled “No resistance changes from zwift”

Some things we tried that helped diagnose and resolve:

  • I can’t tell from your post if you are or are not getting speed response in the Wahoo app. You say it pairs but can’t tell if there is speed there and if you can calibrate. If you can’t, that says you’ve got something getting in the way of the BT connection to the phone even. The Wahoo app is the minimum connection that should work. If it does not, no surprise Zwift won’t either. First step is a discussion with Wahoo support.
  • Assuming the Wahoo app is working, you can try these things:
  • Next thing to look at on your computer (what are you using for a computer) is are other BT devices like an HRM connecting and giving real data? If not, no doubt you have a BT issue on with the computer.
  • Try installing the Zwift Companion App and configure your PC to connect via BT via the Companion App. That worked for me but was intermittent. It at least provided some insight that things could work
  • Try installing the Zwift App (different from the Companion App) on your phone and see if that works.
  • Try installing an ANT+ dongle in your computer and connecting using ANT+. See Bob’s reply in the above mentioned string for the Anself ANT+ dongle from Amazon. It seems to be working well.
  • Install BKool (a Zwift competitor) and see if that software will connect. One more simple test of computer of Zwift being the problem.

Good luck. Let us know what you find with these tests.

I have submitted an online ticket but have not heard back from Wahoo. Do you know of a contact telephone number that could possibly expedite this process?

If you bought it locally you might try them for help. Depending on where you live Wahoo support may have a local support number. Try social media, like Twitter, because sometimes they have a separate social media team.

Also, try downloading the Wahoo App on a few devices like phone, tablet, etc and see if any of them connect to your trainer and allow you to calibrate.

Hey Cole, I did some googling and this problem has popped up before. Wahoo phone support is your best avenue. 1 (877) 978-1112 in US. Previously a number of people had their trainers replaced at no charge to them but call Wahoo and see what they can do.

Their support phone number was hard to find but I ran across it last week when searching. Theoretically you can reach Zwift at 855-GO-ZWIFT between 10:00 am and 6:00 pm Pacific time. I have not tried it so don’t know what their support is like. With all the gyrations I went through and was getting ready to give them a call, I got it working through the help of the folks on this forum.

Hey, Bob. I tried the phone number and it said that due to COVID-19 and inquiry volumes, the phones have been turned off and they suggest submitting an online ticket (which I have). I have received a response from Wahoo that just like all the others are suggesting bluetooth pairing issues – but the trainer pairs just fine to the wahoo app via bluetooth, it just won’t register any speed or anything all all actually. It just connects then doesn’t produce data when in use.

Ya, if you google this you’ll see that previously there was a hardware issue on the pcb. You might try doing a complete reset of your trainer by power cycling it. Other than that I’m not sure what else you can try until you hear back from Wahoo.