Everything connected but Avatar does not move

Hello. I am using Zwift on a relatively new Android S10e, Wahoo Kicker. Downloaded newest Zwift Software. ANT radio app is installed. Bluetooth and location finder is on. It used to work fine until mid December. Now, when I login to Zwift, all paired devices are on (Power source, Cadence) and Controllable) but Avatar does not move. (sometimes Wahoo is conntected via Bluttooth, sometimes ANT, sometimes both.) If I keep pedaling anyway (which is harder on the knees) sometimes it starts working after 20-40 minutes all on its own… without me necessarily changing anything. I am so frustrated. Can anyone please help?

It sounds like a signal interference issue. You might try a few things.

Turn off Bluetooth and let everything connect via ANT+.
Make sure other devices or apps that could connect are turned off or closed.

Hi Bob. thank you. I shut my bluetooth off on phone, and connected via ANT to all three. Avatar still doesn’t work. See attached screenshot. Thanks for your help.

When you pedal do the numbers move on that screen? What I’m looking for is that your trainer is sending over watts.
Also, can you do a calibrate with the Wahoo app?

Hi Bob, thanks for your help here. When I pedal, the cadence numbers move, the rest. Like watts do not. See attached screen shots.
Also, sometimes you’ll see “no connection”. That is no zwift connection…internet is working. I’ve shut off Bluetooth on phone, and delete zwift from laptop to the signals are not competing in any weird way. First slide…cadence 61.
Second slide… cadence 78… but avatar not moving.
Third slide, no signal.
Thanks again for your help.

Hello Bob. I’ve emailed you some photos. Bluetooth is off. Cadence is working on numbers do change, but Power Source and Controllable are not working no matter what I do. I’ve unplugged and changed plug, rebooted phone. This worked until fine until med December. I moved bike from garage to house where it is warmer. Could that have done anything? We did not drop or damage the trainer in any way. See email for screenshots. Thanks again for help.

Cadence will not move your avatar only watts do that. This looks to me like a communication issue for sure and not WiFi,
Can you connect to your Wahoo app and do a trainer calibration? That will confirm connectivity.
It could be your ANT+ dongle is causing an issue so make sure it is seated all the way in. Try removing and plugging it back in. Also, try to get your ANT+ dongle as close to your trainer as you can. Was it closer before when in the garage? Because you may have more signal interference in your house you may need to extend your ANT+ dongle using a USB cable to get it closer to your trainer.
Some things to try and if that does not work maybe a new ANSELF dongle might solve it.

Yes numbers on cadence move. I do not use Wahoo app

If you unpair the whatever numbers dont move such as power then re-pair while light pedaling sometimes the bump fixes it. I had the same issue when starting out. Another connection method can be to pair everything to your phone the select the top right option of use companion app to connect devices.

Hi Bob. I do not have a “dongle”. The Android phone just comes with ANT. No phone is same distance from trainer… maybe Zwift signal was better in garage? Where does the Zwift signal come from?
I do not have a Wahoo app installed on my phone. Do I need to?
I just now, five minutes ago found someone on Linkedin who got me throught to Support at Zwift. Lets see what they say. I’ll come back to you…
Thanks for your help.

Zwift, the game, loads through WiFi but it also talks to your trainer via BT or ANT+.
Yes, there is Wahoo app that allows you to calibrated your trainer and you should do that regardless.
Reset your phone and launch Zwift again. Get on and pedal and try and reconnect everything like @George_Armstrong recommends.
Good luck and keep us posted

THank you. I tried it, twice. Did not work, but in either case I need a more permanent solution since I use it daily.

Penny, for the heck of It I checked your profile in Zwift companion and you’ve been riding for hours, maybe days, but it’s riding riding riding.
Maybe your Zwift thinks it’s connected and riding on some other device. This is on the Companion App.

Bob, that’s because I was riding when it wasn’t working, hoping it would start working as it sometimes does. It got worse.
Yesterday, Zack told me to disconnect devices from phone, and I did. Zwift worked for 5 minutes last night st 6pm…too late for me to ride, but I was very happy.
Now, this morning, I rebooted phone, replicated same procedure today. Not working. Bluetooth is off. All connected on ANT+. Today, cadence is not working either. Please help!
I.am at wits end.
Penny

Well, I checked your profile on my Companion App and you are always riding. I think something is stuck. At this point I would remove Zwift, remove your companion app and reinstall everything.

Ok. Did that but I will do it again when I get home.

Bob, I Uninstaller zwift and companion app. Shut phone down. Rebooted. Reinstall zwift. Avatar still not working, but cadence is if I choose the one coming on on BLE. Does not work on ANT+.
Please see attached screenshots

I just checked your profile in the Zwift Companion app and it still says you are Zwifting now. If you “find Zwifters” in your companion app do you see that you are riding?
Can you turn off ANT+ on your phone and see if the BT will take over all connections?
Settings --> applications --> applications manager --> ANT --> disable

So, either the trainer is not sending out the correct signal format or Zwift on your phone is not receiving it.
Can you run the wahoo app on your phone and do a calibration? While there see if there is an upgrade for your trainer.
Is your phone software up to date?
Is there any chance Zwift is running on another device that you forgot about? Your husbands device?

Hi Bob, yes. I disabled both ANT and ANT Radio and tied it. Everything looked connected but avatar not moving. I will google Wahoo app, see how to upgrade it. THanks for all your help.