Everything connected but Avatar does not move

There is an app that allows you to calibrate your trainer and upgrade the software if required.

Hi, just saw this second email.
Phone is completely up to date.
It worked for 8 months without Wahoo app on phone. I don’t understand why downloading it now will help… or get update to my trainer.
I tried it today both on phone, then on laptop, leaving phone in house so it would not interfer. (Trainer is back in garage to simulate exactly how it used to work) Still did not work.
Husband and his phone are ten miles away. No one else around.

What I may do later is load the hole thing in car and go to friends house where it works. Try mine there. then try my phone her trainer to see if it works.
I don’t know what else to do. It just stopped working out of the blue for no reason.

The Wahoo Trainer app is just an application that allows you to see if it will communicate and generate a speed.


You don’t need it on your phone in order to Zwift. I would install it, do a calibration and an upgrade if required, then you can remove it.
BTW Zwift still says you are Zwifting now so is there any chance you ran Zwift on another device and the game is still open somewhere under your login?

Yeah. I did not logout, I just shut the software. I’ll do that now.
I just updated my Wahoo software, but chain broker on the trainer, so I cannot test it now. Hubby is bringing new chain home.
I reading that there might be a battery in Wahoo kicker trainer that might need to be replaced.

Still Zwifting now. Not so much log out as end your session. You’ll need to end the ride at some point. :man_shrugging:

Hi Bob. Would you happen to know how to replace the battery? I have a Core kicker 18, with three legs

No I don’t but I thought it came with a power cable. I personally don’t know of any smart trainers that have a battery.
Could it be that when you moved it you forgot about the power cable?

You’ll then plug it in using the included 110-240v power block/plug. This cable connects via a small flexible quick-disconnect option on the back of the trainer, in case you trip over the cable (it won’t hurt anything then).

Wahoo-KICKR-CORE-Plug-in

Once powered up you’ll get status lights for power, as well as ANT+ & Bluetooth Smart control/connections on the back:

Wahoo-KICKR-CORE-Power-LED

Make sure you are seeing the lights on your trainer.

If you can not connect to the Wahoo app you may need to reach out to Wahoo support.

Good Morning Bob. I think I am wrong- my Wahoo kicker does not have a battery, and yes, those lights do come on for me. Unfortunately, my chain broke yesterday and my husband brought home the wrong chain…I am using a single speed that someone gave me, so we have to hunt down a new chain before I can test it. Fingers crossed that it will work.
Thanks for all your help. I’ll check in when I get chain fixed

Hi Bob. Just letting you know that chain is broken and my husband noticed cog is worn, so we are replacing those. Probably won’t be able to train until Saturday, if then, so I’ll let you know next week if your fixes worked. thanks ever so much for your help.

While you are waiting for new hardware you may want to make sure you’ve are logged out of all Zwift apps on ALL devices because on my Companion App it still shows that you are riding.
This would also be a good time to download the the Wahoo app and when your bike is back together see if you can connect to the Wahoo app. That will tell us if your trainer and your phone can talk to one another. Just remember to close the Wahoo app completely before starting Zwift.

Bob, check now. I “ended” a ride on PC, and just shut app on phone.

@Penny_Lane, have you installed all the apps in the post below? The radio service and plugin?

Yes, they were all installed.
Right now my hub is worn out and chain broke, but fixing tonight. Fingers crossed :crossed_fingers: thanks for checking. I’ll report back tomorrow.

Yipeee, you have officially stopped your ride.

Bob, do you see me logged out now?

I can’t see you logged out but you are not riding. I can only see if you are riding or not and you are not riding. That is a good start.

Get that Wahoo app and see if you can connect to that. When you get our new chain. Tell your mechanic to get in it! :joy:

You should calibrate your trainer anyway and that is done on the Wahoo app.

Hi Bob. Hope you had a good weekend. I did everything you and Zwift people said. Still not working this morning. Oddly, it worked when we tried it for 10 seconds last night, and in one of my 5 tries this morning it worked for 10 seconds… avatar started peddling, when for 3 seconds, then put foot down and stopped.
I made sure zwift was not paired to phone directly

Can you try connecting to the Wahoo app and also try another device, like your husbands phone or laptop or tablet.
If none of this resolves I think it might be something with the control board in your trainer so best to contact Wahoo.
Or, it could be that a connection inside your trainer came loose when you moved it so if you are so inclined you may think about removing the cover and checking all the connections.

Bob, how do I check inside the trainer? There are no diagrams.
I think it is the trainer because today, after it didn’t work at home, I took it toa friends house who has same trainer. She bought it from my husband who owns a bikes shop. My trainer did not work at her house, but my zwift app worked on her trainer, at her house.
So, to be completely sure,I brought her trainer to my house and my app work’s on her trainer at my house. I have android, hubby has iphone. He wants to test her trainer again tonight when he gets home around 7pm pst. Then we’ll know, and I can pester Wahoo people.
Thanks for your help.
Penny

Your troubleshooting pretty much narrows it down to your trainer. Inside there is one PCB and if we’re lucky a connection has come loose. If not then Wahoo will need to advise on next steps.
I don’t have a Wahoo trainer but it has covers held in place with small screws. You’ll just need to look it over and see if you can figure it out. Look on Yahoo for belt adjustment or replacement and that may help.
The one thing that concerns me is that we know your trainer gets power since the LEDs come on so it may be an issue on the PCB communication chipset. I’m jumping ahead but I think a call to Wahoo is warranted.

KICKR CORE No Power/Speed Issues: This is probably the most challenging issue of all. This is the result of electrostatic discharge (ESD) that results in killing the onboard chip responsible for that. Totally dead killing, no half-deaths here. There’s no recovery from this except a unit swap.”