Wahoo Kickr Connection Issue to Zwift

So this just happened within the hour. Lost my workout window (11 month old was napping).

Hopped on to a Zwift workout and my avatar wouldn’t move. Everything was connected: power, resistance, cadence…but no numbers would show when pedalling. Reset all devices (laptop/trainer), came back, same thing.

Ended up going on to Wahoo app and it was showing my last Spindown as “never”. Not correct I’ve done a few of them. So redid that but found it hard to get to 36kph, like really hard. Was bouncing around all over the seat shifted to the extreme high gear. Thought that was odd but Spindown worked.

Went back into Zwift and numbers finally showed after pairing was complete. Went to do the workout and my cadence was all messed up, really low and couldn’t register higher than 60rpm even with my feet flying.

Shut it all down again, reset, shifted gears because that particular one was a little grindy (I mostly use ERG in workouts), and finally everything was all good. I really hope my final workout window when kids are asleep isn’t ruined later…

I think you need to contact Wahoo support.

Hopefully you had Zwift completely shut off when you were working with the Wahoo app but this sounds more like a trainer issue. Testing in the Wahoo app without Zwift was exactly the right approach. :+1:

Yeah I shut down Zwift and Bluetooth on my laptop. Then used my phone and Wahoo app to test it. Thanks for the help I’ll contact them too!

1 Like

Just to update on this. During my last session I was able to get a moment of everything working fine again. But of course my baby was screaming and I had to leave.

Just tried again and nothing. Same problem all over again. Nothing works. Wahoo Support is of course unable to actually be contacted other than an email. So I’m sure I’ll get some Bot response. Pretty pissed right now. This was working flawlessly just 2 days ago.

This morning I hopped on again to test a free ride. Zwift registered power, cadence and speed. But my power was very low, cadence was accurate, speed was not since power was low (like 14W @ 90RPM).

I saw a comment somewhere about deleting the Wahoo app so I tried it:

I deleted the Wahoo app.
Repaired my trainer to the app.
All power, speed and cadence was registering.
I force closes the app on my phone and turned off Bluetooth.
Opened Zwift on my PC laptop as usual, and it seemed okay.
Started a training plan workout and it was back to normal.

Just wanted to reply and update this chain for anyone else.