Missing Rides in Zwift Companion [SOLVED]

Hi all,

When finishing my training on Zwift (everything works perfectly fine during workout), my training doesn’t upload to Zwift Companion, therefore doesn’t upload to Strava nor Garmin.
The files do appear in my computer, but it seems they don’t connect to Zwift Companion.

In my last upload, the total time does appear + a generic screenshot but no detailed data as usual.

All of this happend after syncing my profile to zwiftpower.com. Thinking the problem was relate to this, I deleted that account, but did not fix anything.

If you can give me any tip, it would be great,
Thanks!!

@Fabian_Flores

Does the missing activity show if you check on the webpage my.zwift.com?

1 Like

I am see recent rides when I search for you using the ZCA.
11hours ago I see a 1hr30mn ride and yesterday I see a 1hr29mn ride.

I also see a lot of other recent rides.

Which rides are missing?

And as @shooj asked are they appearing on my.zwift.com

1 Like

Now it doesn’t show anything at all, as if I didn’t do anything. Although the file is in my computer.

In my last workout (where this issue started) I can see it as my last training, but when I click on it the page doesn’t load anymore.

Thanks Shuji

Yes, the problem started this morning.
If you click in my last workout (1h30) you’ll see that there is no further Data as the previous workouts (where you see the map, the thumbs up, etc)

Realizing this was a problem, I tried to upload new workouts, but nothing happens now.

Thank you Paul

Attached files where you see the file that is working vs the one that is not.

Can you drop the most recent log files into https://zwiftalizer.com/ to see if it might show what issues you are having.

My guess is some sort of internet connection issue.

1 Like

I tried reseting the internet router and nothing got better. Also made sure it was connected to the same WIFI and nothing neither.
I tried your link but I get: “Sorry, an error occurred reading the log file.”

Hmm not an easy one! Thanks for helping

OK, I am seeing 2 different issue if I am correct.

  1. I am guessing The Zwift Companion App is not connecting to the Zwift App

  2. Recent activities are not correctly uploading to Zwift, Strava or Garmin.

Am I correct in that?

1 Like
  1. It’s connecting to the Zwift app while doing the workout - the problem is when finishing the workout. The workout doesn’t upload to Zwift companion.
  2. Correct
  1. is a none issue since it does not get transferred to the Zwift Companion App per say, the activities get uploaded to Zwift’s servers and the ZCA reads them from there.

2.Let’s work on that one

@shooj can you see any issues on your end?

1 Like

This test worked. I don’t know if this helps?

The one little hiccup in the ANT+ signal is nothing to be concerned with.

Now, the couple of errors in the network/internet connection could be what causing the issues.

Are you hardwired or wireless?

1 Like

Wireless. But never encounter any issue until today.
As mentioned earlier I made sure my computer and phone were connected to the same WIFI and reset the router in case something was wrong there. But didn’t solve anything

There is no issue with the ZCA as far as I can tell.

The issue from what I am seeing is your connection the internet and to Zwift’s servers. If possible I would run a CAT5e cable from your router to your computer that is running Zwift.

Is this a PC or Mac?

1 Like

Macbook Air, so no way to connect a cable :frowning:

Should I try running Zwift from my phone and see if it uploads doing it this way?

  • Maybe connecting to zwiftpower.com yesterday messed the connection Zwift app to ZCA?

You could test using Zwift with another device.

If the Zwift Companion App connects to the Zwift App while you are riding there is no issue there. The Ride DOES NOT get uploaded to the ZCA after the ride, the ZCA reads the activities from the Zwift servers.

I have not heard of any issue with connecting to the zwiftpower.com since all that happens is your activities/results get uploaded to that site once it’s complete, nothing is being done while your are riding.

1 Like

@Fabian_Flores
If you did have a flaky internet connection, your FIT file may become corrupted. A malformed file will not read correctly by the server when you save and upload.

You can verify if the FIT file is corrupted on fitfiletools.com to see if this is what happened. Instruction are here.

2 Likes

Paul,

I installed the Zwift app to another computer and road for 3min. Same problem:

  1. Zwift app works and connects to ZCA
  2. Once I finish the training, i log out successfully, but then A. training doesn’t upload B. ZCA doesn’t registers that I finished and continues C. Training never get uploaded.

Zwiftpower.com: That’s exactly the problem, there is no problem while riding. The problem is when finishing, nothing get uploaded.

I tried to do this, but I have different scenarios:

  1. It says that the file has already been downloaded in a private profile (but I can’t find it).
  2. Says the file is not correct
  3. It works, but it’s not solving the problem of uploading the session from Zwift app to ZCA and then Strava and Garmin. As mentioned previously, the fiel does appear in my computer, but just seems it doesn’t get read by ZCA.

Hope this helps. I’m trying to make it as clear as possible. Thanks again!