Today’s ride isn’t syncing with Strava

Usually my workout sync’s over pretty quick. Nothing yet. I logged out and logged in to Strava, checked my profile on Zwift and did the same, too. Now what?

If it is still not there I’d follow these instructions to get the fit file off your computer and upload it to strava through the strava website.

Doing it that way, and Strava says “the upload appears to be malformed and we are unable to process it. “

Rob Styron

Did you make sure you selected the activity with the correct date on it?

If you did and the file has an error in it you could try using the section remover part of this to cut the last bit of the ride out (that’s if this site can even read the fit file with an error in it) https://www.fitfiletools.com/#/top

If that doesn’t work I’m out of ideas.

HI all, same issue here with my ride this morning

I had the same issue yesterday, just download the fit file an upload manually to Strava, that worked for me.

I can do the manual upload, but it is in “incomplete activity” The other thing i have noticed is when you go to Zwift Companion and look at ride, it does not do a “tour” of what you did. THere is just a photo and summary. Thoughts?

Elliot, This just means something messed up during the ride and/or during the saving of the ride. I don’t think anything can be done about this on zwift.

Thanks. Its just that it has happened the last 2 times in a row. I just read it could be because the internet dropped out during the ride, so will test that theory. thank you for replying

You can disconnect internet during ride as long you re connect it before saving. People do it on purpose so they can ride solo. Hopefully it stops happening.