Ride Not Saving

Hi there
I did a ramp test today, about 12km and rode about 30 mins. This allowed me to level up, increase my FTP and unlock items in the store. I clicked save, and when back at the main screen it showed an updated total hours and KMs. However I noticed that my strava did not update, and when I went back into Zwift there was no ride log, no updated stats, etc. The ride was also not visible in the Zwift Companion. The total KMs and hrs were no longer updated as if I did not ride at all.
I was able to download the .FIT file from iOS (I’m using a brand new and up to date iPad Air) however Strava says the file is malformed. I tried using 3 different online .FIT file fixes however none worked, all saying the file was empty or not supported.
I know I had a good internet connection throughout, and I do not even have a partial ride saved.

I know this has been a known bug for over a year. The support chat were unable to help me and suggested I post here so the devs can seen how many people are affected. Anyone have a fix?

Hi @Jesse_Church welcome to Zwift forums!
Shuji at ZwiftHQ here. I’m looking at your recent session logs on our server. I see a workout on Feb 18 called FTP Test (shorter) that was ~45 minutes, 10.8 miles.

Today Feb 20 I see several login & logout attempts of varying short durations where your trainer was paired, but nothing that went longer than 7 minutes. So yeah - the session didn’t upload correctly.

You sound tech-savvy, so I’m going to refer you to this article on our support hub can help you salvage a malformed FIT file to manually upload to Strava.

Can you tell me what was happening on your end? Did the Zwift app crash while you were riding? Did the iPad crash? At any point, did other avatars in the game disappear?

Locate the log files on your iPad. Save today’s log TXT files (there should be several) and upload them one at a time to zwiftwalizer.com. This is a third party site that can parse your logs for potential issues that might be happening on your end. If it’s an internet connectivity issue - zwifatlizer will tell you. If it’s something else - we’ll figure out how to proceed.

Hi, thanks very much for your reply!

Thanks for checking. Yes, there should be a 34 minute ride from today that did not upload. The other logins were likely me trying to figure this stuff out!

When I finished my ride, I pressed save and it took me back to the main screen with my updated totals. I then closed my iPad and opening my phone to realize that Strava had not been updated.

There is only one log.txt file from today - I have uploaded it to Zwiftalizer and it shows no errors, no internet issues, no delayed packets. Is there a way I can send you this information?

I have tried the site you sent to try and combine/fix/upload the .fit files but I get the following:

There was an error processing your activity.:The upload is empty, More Information.

Further, the Zwiftalizer site is saying that I do not have the most up to date version of the game? It says I have version 1.0.45410 not 1.0.45663 however the app store does not give me the option to update and if I delete and reinstall the app, the pervious version is the one available to download from Apple.

Yeah, I saw that notice on Zwiftalizer this week too, you can disregard it. v1.0.45663 is the latest version for Android. 1.0.45410 is the current version for iOS.

Would you take those logs you saved (not just today’s) and email them to support@zwift.com? Please send them all as attachments (don’t copy and paste the text inline). Ask for Shuji in the body of the email and also include the URL of this forum thread. I’ll forward them to the right team to see what’s happening on your end.