Saved rides are NOT showing up on Companion, Strava

I did couple rides yesterday and saved both rides and not able to see them in companion, or Strava. Pluss still having issues with TrainingPeaks.

Training Peaks workouts not syncing. I have tried reconnecting both TP/ZWIFT but not able to find the workout from TP in Zwift. I’ve have one Ipad that I use for zwift only. I have tried other devices with the same results. I also have deactivated/power down all devices and reconnected to my Ipad still no TP. Can someone please help?


hi @Jim_Comment, this is usually caused by either a bad internet connection at the time of saving, or having the game open on multiple devices at the same time. You mention that you have tried other devices, make sure you are saving and exiting each open session (or using the trash can on the save screen) before you open another session on a separate device.

Hello Mike - Yup I went into each device made sure they were disconnected and turned off. I even started zwift today and did save, and still NO change. My internet is running excellent.

did you go for a ride, how long? There is a minimum distance before Zwift will save a ride. I think it is 2km?

1 Like

Hi, quite the same issue here

I finished the Fondo but it’s not showed correctly in the feed and it doesn’t appear in Strava

One of my rides as over 2 miles.

My ride was 50+ km as well

You could both try entering a log file into to see if you are getting network interruptions.

I see that @Jim_Comment had some rides recorded on the 12th, and again yesterday so it must be working again for him. I’ve saved multiple rides since the 12th with no issue.

1 Like

Yes, I get a network interruption in that ride.

BTW I recorded today another workout, as Jim did, and it works fine to me as well.

But… How to fix on my feed the ride with network interruption? It was my first Fondo :frowning:

Sorry, its gone forever from Zwift. You might be able to upload it to strava or other 3rd party apps by downloading the .fit file from Zwift.