Hello! I rode the KISS Down Under race earlier today, but the file was not saved to Strava. I see the event on my Zwift profile, but not on Strava.

All you need to do is download the ride and upload it to Strava manually.

Thanks! My concern is that it was the first time it did not automatically save to Strava after months of zero problems.

Hi Fourie,

This only happens if, for some reason, you connection fails to properly contact the upload servers. If this is the only time it’s happened then it’s most likely an anomaly. If it happens often then there is probably an underlying network issue we help you diagnose.

I have the same problem. And this is constant, happends every time. Anything I can do to fix this? Have tried to disconnect to Strava, to reconnect, but that did help either.

Hi Zwift team,

I have partial downloads on nearly every ride.

Can this be fixed?

I can manually upload some fit files to Strava, but others show a red error message. Love Zwift but this is a little frustrating at times.

Hope you can assist.

I have the same problem as Eric.  It emerged on Saturday.

Hey everyone,

Can you please submit a support ticket and attach your log files from your Documents\Zwift\Logs folder? Just send all of them :slight_smile:


My issue is slightly different.  When I use Zwift on my PC, no problems at all uploading to Strava at the end of the ride.  But on occasion when I have tried to use the IOS app on my ipad, it never transfers the file.  Ride will show up on my Zwift mobile link history, but not on Strava.  Does anyone know why this is happening?


Hi. I have a same problem since 2weeks. Random strava upload. When i finish a race or a group ride my ride is not upload to strava and on myzwift i have a partial ride. I have re-install zwift and reset my strava connection. Same probleme.
I must to import .fit manualy…


Your issue sounds like an internet connectivity issue if you are having issues uploading to Strava and the rides on are showing as partial. 

On myzwift i have partial and on activities folder (windows10) i have complete ride .fit
My computer is connect with rj45
Some riders have same problem at this moment


It still sounds like an internet issue, try restarting your router and see if that helps to resolve the issue.

What other riders, I am not seeing posts about it on the forums.