Ride Did Not Upload to Strava

Hi There,

If your ride doesn’t upload to Strava did you actually ride?

Unfortunately, I completed a ride last night and it did not upload to Strava. So I logged into Zwift to download my Fit file and manually upload it, however, when I click on the activity in my activities it does not load.

To summarize - Completed a ride with Zwift via my Wahoo trainer and Mac. Hit save after ride and nothing happened. No upload to Strava. I check Zwift online and the ride is in my activities, however, when I click on the activity it doesn’t load so I cannot download the Fit file.

Please let me know if you have any solutions.


Hi Patrick, welcome to the forums.

The fit file should be in your documents folder on the Mac, they are saved locally.


Hi Mike - thanks for the tip. I tried that and it said the file was malformed and couldn’t upload.

Any idea what could have caused that? Any way to fix that?

1 Like

Can you use FIT File Tools to fix the corrupted file?

1 Like

Which tool should I use?

1 Like

Try the time adjustment tool.

1 Like

Unfortunately did not work :frowning: I am going to just manually input it on Strava.

Anyway to avoid corrupting the file going forward?

1 Like

It normally happens when your connection drops.

The only time I’ve had it happen to me was when I ran out of space on my hard drive mid ride :rofl:

1 Like

Hi @Skins_Mins - Patrick,

I’m Steven with the Zwift tech support team. It looks like you’ve got some really good answers from the community already. That said, I figured I’d chime in and let you know about this article.

If you haven’t seen it before, it has some good information about malformed .fit files, and ways to prevent partial activities in Zwift.

This isn’t something that should be happening frequently for you, so if you find it’s happening often, I’d suggest reaching out to our support team here, and we’re happy to work with you.

Ride On.