Watopia Mountain - Corrupt FIT file :(

Ergh, Zwift on iPad crashed just as I was half way up to the telegraph tower for the very first time :frowning:

I had definitely smashed my, admittedly poor, PBs all the way up the mountain as well, arrgh! 

I tried re-starting and Zwift did recognise that it had crashed and tried to restart at the same point but just as the scene loaded (at correct location) it crashed again. Repeated this three times then gave up the ghost and went back to main menu and forgot my ride.

I emailed the logs and FIT files to myself and have tried to import into Strava but the files are corrupt. Is there any way I can run the FIT file against a fix utility?

I can see the ride in my Zwift online activity three times all saying “Partial”, only two having download links and both FIT files I have downloaded that way say “The upload appears to be malformed and we are unable to process it.” when trying to upload to Strava.

Any help from Zwift support would be really cool. I was so happy with this ride; depressing to lose that data.

It was the first ride since starting training where I have really noticed my fitness level has increased.

Not sure if this is relevant but I had the companion app open and connected on the iPhone at the same time and that displayed a notification of a Zwift app update at about the same time. Probably just a coincidence.

Sorry just noticed the support ticket option. Will raise there…

Please let us know when and how your problem is fixed.

I also have a corrupt .fit file caused by a zwift crash and would like to repair it and upload it to Strava.

I don’t care enough about loosing my ride data to submit a ticket myself.

1 Like

support directed me to a third party site to fix the file without looking at the logs or the file itself or troubleshooting instructions. not working so far but a but disappointed that they havent looked at the logs and file first and tried to work out what went wrong, especially as we pay a sub to use the service. lets see how it goes, its back with them…

Use www.fitfiletools.com to crop the last few seconds/minutes off your ride and try reuploading to Strava. Thankfully it’s worked for me every time after a bit of fiddling

thanks for the advice, unfortunately it does appear to be completely corrupt.

such a shame but bugs do happen :slight_smile:

I’m probably late for this but fitfiletools.com is pretty dang useless.

this works like a charm: http://garmin.kiesewetter.nl/

Just upload your WHOLE file and let it work it’s magic. My Bryton 530 bike computer was playing games for a while and corrupting the fit files and kiesewetter fixed every single one of them.

Or just drink a quart of coffee and blast all the way up Zwift Mountain again…

I’ve just experienced the same “The upload appears to be malformed and we are unable to process it” error for the first time.

The fitfiletools section remover idea worked for me - I just cropped off the last few seconds and re-uploaded the file to Strava. Everything restored.

I had a similar problem recently. Zwift (or more likely, the notorious nvidia drivers) wedged my Windows machine and I had to reboot mid-ride. I wasn’t too surprised that the .fit file in my Activities folder was corrupted, but then I had what I thought was a brilliant idea: I downloaded the .fit file from the Zwift website. Alas, that file was corrupted too.

I sent in a support request with the suggestion that Zwift should ensure the validity of all .fit files available for download on the web site, and support directed me to post here.

So, here’s the idea: in the event of abnormally terminated ride, the Zwift server should still construct a valid .fit file.

What do you think?

Rode a group workout this morning. Saved the file with no issues… or so I thought. Computer didn’t crash and there was no dropout. It saved to my Zwift account, however, nothing uploaded to Training Peaks or Strava. When I downloaded the .fit file from Zwift and manually uploaded to TP and Strava, it said the file was malformed.

So I followed advice to fix it via https://www.fitfiletools.com - this restored some of the file but most of the data was still missing. Then I used http://garmin.kiesewetter.nl/ - no luck again.

I then found http://fitfilerepairtool.info/ which you have to pay for… I’m very reluctant to try it as worried it will fail again and would have wasted £32 in the licence fee. 

Heres the file 

Can anyone help me?

Zwift crash and I tried to download the .fit file and upload to Strava, didn’t work corrupted file

Then I tried using keisewetter.nl to fix the .fit file, for upload to strava, didn’t work, Strava now says “it is not an activity”

Then I tried fitfiletools.com “corrupt time fixer”, and upload to Strava, worked like a charm :slight_smile: