Zwift File not upload to Strava due to "Malformed File"


(Peter Emmett) #1

In the last month or so I have had intermittent issues with files not being uploaded to Strava. When I try a manual upload from the downloaded Zwift .FIT file I get the following Strava error message;

“The upload appears to be malformed and we are unable to process it.”

Anyone else getting the same?

 


(Thomas Ly) #2

i get this issue if i experience no internet connection during a workout and it corrupts the file


(Jade Waits) #3

From what I’ve noticed, it sometimes happens due to the time stamp on a FitFile. There is, however, a site that allows you to fix these files.

Simply go to this website https://www.fitfiletools.com/#/top and locate the icon on the bottom left that reads “corrupt time fixer”, then launch. Then manually select your FitFile from My Documents/Zwift/Activities in your computer. 
You can then choose to download the file, or directly upload to Strava!


(Sententsiya Sport) #4

I have everything in order with the Internet, but the track still does not load in strava.In addition, the screen shows one distance that traveled, and when you save the track a smaller value. This is outrageous, what nebylo in the trial version of this game, why now?
If this is so, then Zwift will have to give up.I’m very sorry. I hope that the mistake will be corrected.


(Nicolo Bottazzi) #5

Same problem to me, just starting from the recent version / upgrade of zwift. This issue only persist with workout and not with normal route cycling mode.  I figure out to resove this issue with https://www.fitfiletools.com/#/top but hope that zwift guys will resolve it with next release.

I also suggest you to implement a “auto resize screenshot” so if I made a screenshot with a 4k TV I won’t have a too large image maybe to upload to zwift that probably will be delated. 

Do you have plan to have this feature released in the future?


(D Gwreck) #6

I’m adding a comment to this issue that might help cases where Zwift session connection was lost during a ride and attempt to manually upload the fit file to Strava fails with “upload appears to be malformed…unable to process”. 

This happened to me today (my fault as my laptop ran out of power), and I tried using the FIT File Tools/Corrupt Time Fixer option to fix the file ,but, it still wouldn’t upload. I tried that option 3 times with no success. 

Then, I started & completed a short 2 minute Zwift ride, but, I didn’t upload it. Instead, I used the FIT File Tools/File Combiner option to combine the “bad” fit file (first ride that was interupted) with the “good” fit file (2 minute ride ), and it then uploaded successfully. The ride can be trimmed as needed once in Strava… Note; It connected a straight line from my last location when I got disconnected … back to the starting line of the 2 minute session. That’s the part that needed trimming.


(Sarah Watmore [FEAR]) #7

I managed to use the corrupt time fixer tool on the second attempt to upload my malformed file by ticking the time jump option. But it has dated my ride Jan 2015 and I can’t see how to edit that and change it to 14 Feb 2018. Is it possible?