Corrupt Zwift file.. fitfiletools did not fix

Rode a group workout this morning. Saved the file with no issues… or so I thought. Computer didn’t crash and there was no dropout. It saved to my Zwift account, however, nothing uploaded to Training Peaks or Strava. When I downloaded the .fit file from Zwift and manually uploaded to TP and Strava, it said the file was malformed.

So I followed advice to fix it via - this restored some of the file but most of the data was still missing. Then I used - no luck again.

I then found which you have to pay for… I’m very reluctant to try it as worried it will fail again and would have wasted £32 in the licence fee. 

Heres the file 

Can anyone help me?

Tends to be a corrupt time for the most part.  Try the linked file.





Have you tried the .fit file from \documents\zwift\activities 

Hi Ray

Thank you for your help. However the file you saved was the same as when I tried - it cut out a lot of the data - see attached screenshots - my zwift activity vs the upload after fitfiletools 

That may be as good as it gets.

Thanks Ray - apparently this is much more in-depth and thorough: but don’t want to risk buying if it doesn’t work… we’ve all got more important things in life that we should focus on… 

True, like riding…