Missing Rides in Zwift Companion [SOLVED]

Ok, this is not a Zwift Companion App issue and it is definitely not a zwiftpower.com issue, this is an internet connection issue. The issue could be with your ISP.

I think you are getting confused on the way the Zwift activities get uploaded.

If there is an internet issue near the end of your activity or during the update process the .fit file will not be uploaded since it will be malformed.

Again, Zwift activities DON’T get uploaded to the ZCA, the ZCA only reads what is uploaded to the Zwift servers.

This is an internet connection issue either at your house or at your ISP. My guess is your ISP since the issue just started.

Have you tried restarting both your modem and router (if they are separate devices).


Your ride have to be atleast 2km for it to be upladed to Strava.


I restarted my router, made sure I was on the same WIFI connection + rode more than 2k and it FINALLY worked!! YES!
THANK GUYS! @Gerrie_Delport @Paul_Allen @shooj


I would make sure your router has the latest firmware updated as well, usually routers should not need to be rebooted for a single app to work inside your network if everything else you do works, unless it has a potential bug or resource problem in it.

1 Like

Same error happens to me usually, activity details can not be retrieved on companion app nor Zwift page. Also activity doesn’t upload to Strava (need to upload it manually). Today on TOW4 closed Onedrive to avoid sync problems and Garmin Express. Here’s the network log.

Clicked save on the companion App, then zwift didn’t respond. It freezed. Zwift closed without route selection.

Activity just don’t load:

Hi all,

I have a quite similar issue and not sure what I am doing wrong.

When I ride using only the laptop in front of me and finish and save the workout I get an upload to strava and registered workout in my activities.

If I however use the ZCA during the workout it gets corrupted somehow and after finishing and saving nothing gets uploaded or registered in my activities. Also nothing is found in the .fit files folder.
I am on the same wifi with the laptop and the app.

What do I need to do differently?

Best regards,