Kickr Late on Picking up Hills

Hello and good afternoon all! My Kickr Rollr is working out great and I’m actually happy with this roller meets trainer. One thing that is an issue, however, is that it’s late on picking up hills. That is to say, I’ll be halfway to three quarters up a hill before the resistance changes.

What do you all think is causing this? My setup is as follows: Windows 11 on a laptop for Zwift, a Garmin Edge 530 (Which is not linked to the Rollr or my power meter) A Rally XC100 Garmin power meter, an ANT + dongle, an HRM heart rate monitor, and of course the Rollr itself.

I should point out that I have “maxed out” the trainer difficulty on Zwift. If anyone has any suggestions, they’ll all welcome and appreciated :smiley:

Stay true,
DJP

try connecting the rollr via bluetooth if possible, i have always find that reacts quicker than ant+

2 Likes

Hi thanks, I should point out it is connected via Bluetooth (I just stated I had ANT to let everyone know my set up - but thanks for the suggestion; I should have been more clear!

Stay good,
DJP

maybe try ant+ then! at least rule out the connection being the issue

That’s a good idea. I will give it a shot (after dinner lol)

Thanks!

Stay true,
DJP

You might try uploading a log file to zwiftalizer.com to see if dropouts are an issue, but if it’s consistently always late that doesn’t sound like a random dropout situation.

That’s a good idea too, thanks Paul and Chris, really getting a lot of help from these forums!

Very best regards,
DJP

When you say “I’ll be halfway to three quarters up a hill before the resistance changes”, how big a hill is that, so are we talking a few seconds up a small ramp, or kany minutes up a sustained climb?

I guess.you have connectet your Garmin powermeter as power source and the rollr as controllable.
Please try to connect just the rollr as power source and as controllable.

Connecting external.power sources and a trainer as a controllable results in a slow feedback loop.

And, does the hill resistance end on time, when you get to the top, or is the lag equal on the other side of the hill going back down?

If you want to control your Kickr with the pedals, use the feature in the Wahoo app.

1 Like

I have never had an issue and I always use a different powermeter to the trainer

Same logic applies here.
To rule out a slow feedback loop.
Or do you have experience with a rollr and the same power meter as he got?

why would using a separate power meter affect the trainer resistance though? the two aren’t related.

Normally you connect the trainer as power source and controllable.
The trainers regulates it’s resistance with the in input of it’s own powermeter internally with the workout data received from zwift.

If you connect an external powermeter to zwift and the trainer just as a controllable, the powermeter data has to get to the computer, is calculated by the zwift software, combined with the workout data and the sent back to the trainer to set it’s resistance.

Sorry if my first statement was incomplete, the aforementioned only applies to workouts in erg mode.

Hi folks! Wow, great discussion! To answer Cris, I do ensure that the Rollr itself is the “Power Source,” but good point. And to answer Steve, so far I’ve only tried it on smaller climbs but even then it takes awhile. And to John, it is very interesting you should ask! I do notice that after an incline, there is still some lag on a flat surface for a little bit before the resistance resets to the normal, flat terrain.

All great points and questions, thank you very much :smiley: I want to try this ANT+ business and I have an ANT+ dongle; however, the Rollr itself at least under “Controllable,” only appears with a Bluetooth icon, how in the world do I switch it to ANT+. And when I do, should I change the Power Source and Cadence to ANT+ as well?

Thanks again folks, stay true,
DJP

that is only the case for erg mode but as the problem is late reporting of hills then the power source is not involved in the resistance zwift sends to the trainer.

Yes, sorry.

1 Like

Hi all, so I tried connecting the Rollr through my ANT+ dongle, and I sort of did… check these out, when I went to pair, I was greeted by the following windows:



The only ANT+ option was a Wahoo FE-C one, so I selected it as Power Source and as Controllable, and it worked! I was moving around in Zwift and I didn’t even select the Rollr; what is happening??

that is the rollr - ant+ don’t have names like bluetooth the number is the ID