Issues with Elite zumo

Hi,

My elite zumo has been working fine up until today, I went to do a session at lunch as there was no resistance change, just spinning along with no difference in up or downhill.

So I thought I’d do a spin down calibration on my trainer using the elite app, as I can’t see where to do it in Zwift?

I did the spin down calibration and got a result, saying success.

Go back to Zwift and the resistance is huge for the given wattage on the screen. I really can’t figure out what is happening.

Can you give us a bit more information, how do you connect to Zwift (Ant+ or Bluetooth) and what system do you use for Zwift (PC , mac or Phone)

turn everything off (including PC/phone and anything that may be sneakily using Bluetooth!) and start again! usually fixes most things

I connect via Ant+ on my laptop, there is a bluetooth mouse that I use.

Zwift is on my windows laptop

I’ll give that a go and see what happens, thanks

When you pair the trainer as controllable be sure to select the FE-C option.

1 Like

Will do, thanks

1 Like

None of those options worked, I’ve emailed Elite to see if they have an answer

I had this same problem tonight. Zumo was working fine until I did the spindown calibration. I got similar spin down values to you. I checked the power in the elite training app and those values no longer look realistic. I think I must now have a very poor calibration but I’m not sure how to put it right. If you have any success, please let me know!

Was your spin down time long? My spin down seemed to be with no load from the trainer so takes 30seconds plus.

Very frustrating, wish I had stuck with the factory calibration!

The spin down seemed to be unloaded like you say, then power was all over the place.

I did a test that Elite suggested,start a 1 in level mode and ramp it up to 16, resistance was fine, power was totally wrong.

So I just rang Halfords, explained the situation and they said bring it in and we’ll swap it for a new one.

Plugged it in, set it up on Zwift (no spin down) and it worked perfectly, proper resistance change and realistic power outputs. Job done.

Have you been brave enough to try a spin down calibration with the new one?
I took some more screenshots of the power measurements today which I will send to elite tech support. Curiously the power measurements on resistance level 1 look fairly sensible but then as I go up the levels the power drops off whereas it should build.

Nope, not doing it either.

Just to close this topic…
Had a response from elite today after sending them the trainer map. They told me the trainer is working fine but the spindown did the calibration in reverse hence the reduction in power measurement with the increase in level. They have advised me to take it back for a replacement.

That sounds exactly like what I got, glad its sorted

sorry to resurrect this old thread - I have had a zumo for a few months and it was working fine (albeit with very inaccurate power readings) did a spin down the other day and in erg mode the power just gets higher and higher until I can’t turn the pedals

has anyone returned theirs to halfords? what did you say was the issues and did you need to contact elite first?

Just take it straight back to Halfords and ask to swap for a Direto, that’s what I did and it’s been trouble free

I had the same problem as Chris I went around to Halfords today and they have agreed to exchange it for a Direto and I will pay the diference.

Hi folks

Sorry to jump on this thread but ive just bought a Zumo and keep having fluctuating power readings of +/- 40 watts.

Im connected via BLE as the controllable feature doesn’t work on Ant :man_shrugging:

My Zumo is now stuck on full resistance after a spin-down test. Now is almost impossible to pedal, yet only shows im putting in about 50 watts. Unfortunately for me, all the shops are closed in NZ and therefore I cant return it.