Elite Suito issues or features

Hi all, I just bought an Elite Suito. Did a test ride tonight and I have a few things I’d like to validate if it’s normal behaviour or a trainer issue. I did a spindown calibration on the Elite myETraining app, trainer is running the latest firmware. My gear’s on the smallest ring on the front and the middle on the cassette. I’m comparing my experience with my previous trainer (Tacx Vortex Smart)

  • Output wattage fluctuated alot. Like +/- 20w with almost every pedal stroke (tested in erg mode)
  • The wattage from the Suito seems alot harder than the same wattage on the Vortex Smart
  • Can’t get the power meter to connect in the myETraining app

Do any of you have similar experiences / issues?

Thanks in advance!

Hello,

I also have the Suito and I managed to update the Firmware, but MyEtraining recognizes the Suito, but not its two sensors, so I cannot use this application.
Fortunately, it works with Zwift which recognizes Suito well. Only problem, the calibration fails under Zwift. Do you have the same problem?

Thanks.

Hi Alban,

If you delete and reinstall the myETraining app, you can add the cadence/power sensor. That worked for me. Ive reached out to Elite support and they say that if you use Zwift you only need to do the spindown calibration in their app. I have the same issue with the Zwift calibration (timed out).

What’s your experience with the Zwift wattage?

I have used the Elite Suito for just under two months now and had no significant issues with the device. In response to the spin down comment, I could never calibrate the device with Zwift but by using the (painfully awful) Elite my-training app, I could perform a spin down and the device would save the calibration.

The Suito now appears to be knackered - I now find that it ramps up the resistance like it has a mind of its own. I went to enter a Zwift race and, even during the warmup at the start, the device went from next to no resistance to over 400w, all the time whilst making noises to suggest that the resistance was jumping all over the place (the same noises that occur when the device is first switched on and it, perhaps, calibrates itself). Having stopped pedalling, the device dropped the resistance off. When starting pedalling again, it would do the same. Almost like the reverse of ERG mode. This happens regardless of the gradient, or the power that’s required using Zwift. I was able to reproduce this same malfunctioning using sufferfest, the Elite my-training app, and with my Wahoo Element connected to the trainer in passive mode. Bizaarely, when the wahoo is connected to the trainer with a target wattage, the Suito behaves as expected. Power cycling all devices, changing devices (from my iMac, iPad, iPhone, wahoo) all generate the same glitchy behaviour.

I hope I’m not alone and there’s a simple solution out there, something that I have overlooked. I have reached out to Elite for their thoughts but thought I’d share in case there was anyone else out there, or someone who knows something I’ve not tried?

2 Likes

@Paul_Holloway I have exactly the same issue as you. This has only just appeared after months of trouble free riding. I don’t know whether this is related to a) updated firmware or b) attaching to my wahoo headunit for the first time.

Are either of these things new for you too?

It seems to work ok in ERG mode too.

I had recently connected my Wahoo element. Having disconnected and unpaired it, I still experienced the issues. Fortunately I returned the Suito for a replacement and I’m now back to usual. The new Suito (which appears to have a slightly better quick release adapter, too) works fine with my powermeter. I’ve not tempted fate by going into the Suito app and trying anything fancy.

Thanks @Paul_Holloway. Did you get any useful response from Elite support or did they tell you to just return it?

Is there a solution
just had the same problem
is unusable now

Suggest you try to get a replacement if under warranty or contact elite at info@elite-it.com. I tried all manner of things and nothing helped.

Good luck

Thanks,
yeah i just bought it a few days ago and used it the first time today…

To everyone who might have the same issue
Until we hopefully recieve a new trainer (because obviously it is bricked), here is how you can use it

  1. You can control the wattage via the Wahoo head unit
  2. You can set the Wahoo to Passive Mode and then simulate the Work-Outs from Zwift. But be aware that the routes in Zwift are not working, just the ERG workout mode

Hello guys,
I bought Elite Suito 2 days ago. Yesterday I did an FTP test and it worked perfectly, but today I wanted to ride and had same issues as you described. Biggest problem is resistance changing all the time and for example, I’m in the lowest gear, slope is 0%, cadence is 45 and it shows I’m riding 30 kph. This doesn’t make sense and sometimes it showed me I’m riding 130 kph.
Did you manage to solve your problems yet?
If you have any idea what to do, please let me know.
Thank you guys and enjoy riding

Have you also connected the unit to a wahoo computer?

Mine unit seemed to also work fine until I connected it to Wahoo Bolt.

Yes I did connect it to my Wahoo Element Bolt yesterday, during my FTP test. Do yo know if there is any way to repair it?

No, I’m juat trying to figure out if it’s the common factor or not, but it seems it is.

The ERG mode works fine, but SIM mode doesn’t. I guess I’ll just replace my unit under warranty since I bought it just last week.

I’ll try to unpair them and see what happens. If nothing’s better I’ll just go to replace it. Thank you for your answer man.

Let me known if it helped, because it didn’t for me. At least I had the same issue in Zwift today with Bolt turned off :frowning:

Yes me too but maybe to restart both devices and forget each other. If I succeed I will let you know😁

So I got a reply from Elite. It’s known bug and it’s possible to fix if using a firmware upgrade via Upgrado and new firmware. But they forgot to attach the actual firmware :slight_smile: So now I’m waiting for the firmware link.

Same thing happened here. They forgot the link to the firmware.