Sprinting on Zwift with a Elite Suito

I regularly participate in group rides on Zwift. I recently changed to an Elite Suito, I’m finding sprinting is nearly impossible due to lack of resistance and cadence regularly exceeding 150 rpm with peaks recorded as 200+ (which I don’t believe).

When I sprint out of a group I would expect resistance to increase as draft reduces but it feels like resistance reduces, power reduces as my spinning tends to reduce and power tapers off. Power peaks at about 650 W.

Is this normal? Is this how the flywheel feels?

I’ve increased trainer difficulty to 80% but will now change to 100% on Zwift. Will this help?

Performed calibration using elite software, spin down value is 10468 ms, slightly higher than factory figure, but consistent.

Any advice is welcomed.

Are you changing gears when you want to sprint? Trainer difficulty will only “feel” different on inclines and declines, it will have no effect on flat roads. The draft doesn’t change resistance on smart trainers to my knowledge either.

Hi @Gary_Cairns
I’m looking at your session logs on our server and I’m seeing the Elite paired as your power, cadence and controllable trainer devices. Simultaneously, there’s a Tacx Blue Motion paired as your trainer, and this might be throwing it off. Is the Blue Motion the trainer you were using previously?

  1. I’d like to have you start the game app, and unpair everything and re-pair carefully. If the Tacx is powered on, please power it off before you do this. Hopefully this configuration will be remembered moving forward.

  2. If that did not solve the problem, let’s try a manual uninstall / reinstall that nukes the entire configuration stored on your computer. Follow these steps please. Further down that discussion - please also follow these steps.

Please loop back and let us know how this worked out?

1 Like

I’ve followed all instructions including deleting pref.xml and removing and installing Zwift. Tried sprinting today, notice that cadence sensor doesn’t appear to be synched, still high readings on Strava is 250, when I stop pedalling expecting lag of 1-2 seconds but is probably closer to 10 second which is about same as spin down value in calibrating trainer. I can forward fit file if that helps?

1 Like

New pairing option this evening elite real world feel more realistic,

When I’m pairing my Suito I’m getting two or three options via Ant+ with Zwift installed on pc. I started by pairing power meter selecting pwrxxxx where xxxx is a number. I chose this as the icon in search was identical to power symbol. In cadence I can choose both pwrxxxx and F-EC sensors. In the controller I get three options pwrxxxx, F- EC and one called Elite Real Trainer. Initially I’d selected the F-EC but didn’t feel resistance, I then selected elite real trainer, with difficulty at default didnt notice resistance. Set difficulty to 100% and even on flat it was difficult to maintain power output and didn’t feel realistic.

Cadence sensor appears to react on flywheel not on stopped pedalling with lag of 10 seconds before it stops pedalling on screen.

On subsequent rides even with controller on elite real training don’t feel resistance.

Ive ensured elite is on latest firmware and calibrated once a week.

Any suggestions on what else to amend to make it feel realistic and consistent?

If you actually have a power meter on the bike (is that where the pwrxxxx comes from?) use it both as power as cadence, as it would be much better than the sensors on Suito.

If you paired the PM to the Suito using the “Advanced configuration” option and enabling “Power Link”, I recommend disable it (as it will result in delayed power figures), then use the “Erase” button on the same window to remove any hint of the PM from the Suito (otherwise it confuses things) and restart your trainer after saving the changes. Always prefer a direct pairing to the PM for power/cadence. That solved most of the issues in my case with the Suito. So I basically use it as a fancy direct-drive resistance-wheel.

Kemal
Thanks the power meter is integral to smart trainer don’t have external one but thanks for the heads up. I think my issue is the resistance ‘controller’ sensor doesn’t react with changes on Zwift ie it’s not smart.

To illustrate climbing 10% climb on watopia (default difficulty last night) 110 rpm in a 52 X 11 gear. No noticeable resistance unrealistic cadence and 2.2w/kg.

I will test it over weekend with elite e-training app which I suspect will work. If lack of resistance problem persists on Zwift I will contact retailer.

Thanks

Use the FE-C connection for all the pairing options. Power, cadence, and controllable.

2 Likes

Mike
Thanks will try that option.

Regards
Gary

2 Likes