Elite Suito Resistance problems

I have an Elite Suito since december, witch I’ve been using with zwift without any problem, until yesterday. I was zwifting, without any problems and I turned on my Element bolt to see how was the battery, without intention to connect it with the elite. After they connected I’ve been getting a ressistence problem that when I start pedaling connected to zwift the resistence turns on as I was climbing. I have reinstalled zwift and nothing changed.

Olá @Daniel_Moreira1 welcome to Zwift forums.

Shuji at ZwiftHQ here. Question for you: When you powered on the Element Bolt - did the trainer disconnect from Zwift? It should not have. I think maybe the change in resistance is from another cause. Here are three things in your case that might be happening:

  1. The default mode for Zwift is called SIM mode, for simulation. For a controllable trainer such as the Elite Suito, the game will change the resistance of the trainer on uphills and downhills to simulate the real world.

  2. Furthermore - in your profile, you can customize your trainer difficulty setting from 0 - 100 %. Setting this to 50% means that a climb of 10% gradient will feel like one that’s 5%. There is an effect on the descent as well. Your downhill coasting speed will also feel like a 5% hill. You’ll have to spin faster if you want to keep up with someone else whose trainer difficulty is set to 100%.

Looking at our server logs, your trainer difficulty on March 23 was set to 0%. On March 24, it changed to 14%. That’s enough of a difference that you will feel the hills in SIM mode especially at your FTP setting. Please try adjusting this and see what you prefer. The default setting for Trainer Difficulty is 50% by the way.

Lastly - if setting Trainer Difficulty to 50% makes it much too difficult, please consider lowering your Function Threshold Power (FTP) number. This is the amount of power you can sustain for a given time, and is the basis for everything in Zwift. Set it too high, and everything is difficult. Set it too low, and everything feels too easy. Do that in your profile as well.

1 Like

No, it didn’t disconnect.

I’m using 0 trainer difficulty for while with no problems. I changed it to see if would make a difference but nothing changed. I just did a short ride with the difficulty on max. both up and down a hill and there was no diference. The resistence was the same going up and down hill. It feels like theres is another program controlling the trainer, but the bolt was turned off.

Since the original post I connected the trainer through the companion app but nothing changed either.

@Daniel_Moreira1

Were in you in a Workout? If that’s the case, you were probably in ERG mode. This mode keeps your wattage target steady, and resistance does not change with uphills / downhills. All you need to do is stay seated and keep your pedal RPM’s high to meet the wattage target.

The point of ERG mode in workouts is to keep you in a steady-state effort (80% of your max for 2 minutes, then 60% for 4 minutes of recovery, then back to 80% for the next hard block, etc) and lets you ignore terrain.

If you were not in ERG mode - the next thing I’d check is outdated firmware on the trainer. Elite has a mobile app called the Upgrado that handles firmware updates.

No

It says I have the lattest firmware.

Edit:
When I got the trainer I had the option to do a spindown, I don’t get it anymore.

Any update on this? I have the same issue… I have an Elite Suito and I have been using it without an issue for the last three months. Last succesfull ride was on 24/04.

Yesterday I was able to do an FTP test, ERG mode seems to work fine.
But when riding around freely, I need to turn 300W+ in 34/32 to get any cadence.

When I control my Suito with my Bolt, I can set it to certain watt levels, and turn a nice cadence, no issue. The moment I try to reconnect to Zwift, resistance goes up to unridable levels.

I have the last version of the firmware, checked it with Upgrado

Did you fix your issue with the resistance? I’ve got the same trainer and am having the same problem. Suit works fine in erg mode but in sim mode resistance is way too hard. I have calibrated the trainer in the elite ap successfully. Problems started after I paired my wahoo bolt to the suito. Have unpaired it now but issue remains

Fix the resistance issue by starting a MyETraining app workout, as I detailed here: Elite Suito issues or features

Good luck :slight_smile:

1 Like

Hi all, I am having exactly the same problem, nightmare! I have checked software in Upgrado, configured in Elite App and checked Level Modes all good. In Zwift I have also configured and put Difficulty to 100% and checked FTP correct, both with ERG OFF and ON and still no resistance when going up a 12% hill, please help!

I emailed elite (info@elite-it.com) and they solved the problem with ease. What happened is the bolt overwrote the suito circumference Wich can lead to many problems, one of them this one. I think that now, you can fix the probem by connecting the myEtraining app to the suito

Thanks for the solution! I found it out myself the hard way, by trail and error, but I can cofirm this works.

I had a problem where my suito would ramp up the resistance for no reason on zwift with nothing changed or added. The fix for me was returning my trainer under warranty for a replacement.

I have a new Elite Suito - out from the box - it is not showing any resistance on Zwift. Unable to callibrate on zwift as well.

Tried using My Etraining and reisistance works on their app. This is really frustrating.

Any suggestions??

Catherine

Hello zwifters
Today i get a suito Elite out of the box :grin: :crazy_face:
i connect it to zwift immediately and BOOM resistance on and silent spin all :star_struck: :star_struck:
i decided to calibrate the unit and go to myetraining app and did all the steps and back to zwift
i recognize that there is no resistance … and spend about 3 hours breaking my head on/off the bike connect phone connect laptop, disable this disable that, upgrado … nothing work !
i give up :sweat_smile:
i decided to connect it with my Garmin 520 edg, but before i turned off bluetooth from phone and shutdown my laptop :rofl: to ensure that the suito will be connected to my garmin only, and as a last step i reboot the unite (suito).
the garmin detected the suito as home trainer i did calibration i launch garmin and immediately switch on Zwift on laptop with bluetooth connection only and Boom !!! the resistance is back !!! i was so happy and exited and decided the do some climbing workout as my legs was fresh, but before i deleted myetraining app from my phone :yum:
after 45min of climbing at avg power of 244w i decided to turn off resistance my self :laughing:
good luck !

Please help!! Erg keeps kicking in on non work out mode on zwift. I have an elite suito, i use a samsung phone and i have tried everything!! Please someone help, thank you.

My solution to a similar problem. Connecting my Wahoo bolt changed the circumference to 2070, which might seem fine, but is the cause of the problem.

Deep in the Elite Suito manual, it says the circumference is calculated by dividing your normal wheel circumference by 24.8.

In the myETraining App I changed the circumference to 86. Then went back in Zwift, and everything was back to normal.

Not intuitive, but that’s the solution.