Problem with Elite Suito


I used the elite suito for 3 months now… Everything was working, no problems.

But since 2 weeks I have the problem that the resistance does not change uphill and downhill during a free ride. In the training-mode the resistance changes according to the plan, but not in free ride… no matter how steep it is, the resistance is always between 95 and 105 watt…

I have tried all tipps i found in the forum, but nothing worked.

I have already tried the following steps:

  • Deleted zwift and installed it again.
  • Calibration with the Elite MyTraining app
  • Checked the firmware with upgrado
  • Tested it on Mcbook and Ipad, both the same problem

Does anyone have further ideas, what i can try?

Thank you!
Best regards!

Hello @Gernot_Scheibenpflug, welcome to the Zwift forums.

How are you connecting (bluetooth or ant+) and to what device (mac, PC, iphone, android, etc.)?

When you are in the free ride mode and you go to settings is the trainer difficulty is the slider bar visible and can you adjust it? The behavior you describe is when the trainer difficulty is set to 0%.

Thanks for your fast reply…

I normally use a Ipad pro and connect with bluetooth.
This was the original setting which worked for nearly 3 months without problems.

Today I also tested it on the macbook, also with bluetooth.
But with the same problem than on the ipad.

best regards!

The trainer difficulty was on 50% … i also tested it with 100%.
But no changes when i set another value…

J’ai le même problème que vous avec mon Elite suito. Avez vous réglez le problème
Merci JN boissinot

Can you try riding a route in the Elite MyTraining app and see if you get the same problem? (I think you can ride a simulated route in the Elite app).

This is a bit odd. So, in a free ride, no matter how fast you pedal or how steep the grade your power output is always between 95 and 105W.? That sounds like ERG mode might be stuck on. I don’t use ERG mode and I thought you could only use it during a structured workout but again I am not sure.
The fact that you have the exact same issue on various platforms, Macbook AND IPad, makes think that it some communication error between you trainer and Zwift. Since the constant is Bluetooth you may want to try ANT+. in the MACBook but usually, as you said, Bluetooth on the Ipad is rock solid.

Remove Zwift from all your devices and then re-install it only on the Ipad. Make sure there are no other devices like a head unit trying to grab your trainer BT signal. Make sure your ERG settings in Zwift are correct. Other than that I’m at a loss but there are lots of really great techies here so maybe something will stick.


thank you for your help.

I have now removed zwift and all other elite apps (mytraining, upgradio) from my devices.
Then i installed zwift again on the ipad, but same problem as before. Everything works fine during
a training… but in free ride the resistance does not change… even if there is a uphill with 12% I am on about 95-105 Watt. same in downhill… always around 100 watt…

I also tried a spindown calibration, which seems a bit strange… Because normally you should reach 36kmph, but now i only make 12kmph and the calibration finishes…

Also the calibration in the elite app seems a bit strange. There i should reach a speed of 7,9kmph…

I would be happy if anybody has another tip for me?
Otherwise i will try a ANT+ dongle on the macbook…

Best regards!