Inside Ride SmartPower Resistance Control - Problems connecting with Apple TV since the 12/30 update

I’ve been using Zwift with Apple TV for over 3 years, and completely trouble-free since the software update that came out on December 30. Zwift connects to my devices as usual, but Zwift won’t adjust resistance on my trainer. I’ve tried erg mode on and off, and no difference. I went to the “contact us” button on Zwift and there is a box that says “known issues” but there is no date on this and I don’t know if this is related to that release to 1.20.1 (1.0.100278) (December 30 2021). Is anyone else having issues with Zwift via Apple TV?

thank you


I am a relative newbie, but all was well with Apple 4k gen 2 plus neo 2t until the 1.20.1 update, now can’t pair at all. Tried all the tricks.

Same problem here. Trainer won’t adjust the resistance normally when using apple TV and Companion app with iPhone.
Downhill feels harder ja uphill feels easier.

Hi @Dave_Petrie
Thanks for flagging this up to us. The Inside Ride SmartPower resistance control unit for your rollers is one of the units having issues after a broader Bluetooth improvements that were made for all controllable trainers. Some more context is in this post.

We are aware and working on it.

1 Like

Shuji - Thanks very much for this update. I’m controlling the SmartPower unit manually now, and it enables me to still use Zwift and hit the wattages requested in the Build Me Up plan.