Looking for users of InsideRide E-Motion rollers with Apple TV

I’ve been using Zwift with Inside Ride rollers for over 3 years. The December 30 software update killed my setup. Are any others that use E-Motion rollers with Apple TV having resistance issues?


Killed it how?

hi Lin…

I’m an experienced Zwifter with over 8,500 Zwift miles on my setup - nearly all of these miles were logged with my InsideRide rollers accessing Zwift through Apple TV. The rollers have a resistance unit called Smart Power and its always worked fine via Apple TV. Since that 12/30 update (which I installed after my workout on 12/31/21), my devices connect normally, but my rollers won’t respond to resistance changes from Zwift. Now I have only 2 modes… minimum resistance or maximum resistance, whether ERG mode is on or off.

Minimum resistance occurs for any grade up to 3% (including negative values), then when the grade on Zwift goes to 4% or above, the trainer switches into max resistance mode. There are yellow lights on the unit for MIN and MAX so I’m certain this is happening (I’ve attached a screen grab)

This identical behavior occurs with Apple TV and with an Apple laptop which also has the most recent software update. I’ve written to Inside Ride about this and they don’t have an Apple TV to test it. Again, everything worked normally until that 12/30 update. I was hoping to find another user of these rollers with Apple TV so we could compare results.


Screenshot 2022-01-04 at 08-07-24 SmartPower+draft6+doc pdf

Zwift setup:
InsideRide E-motion rollers with Smart Power resistance unit
Assioma Uno power meter
Apple TV running 1.20.1 (100278)

I don’t see these rollers listed on the page of Zwift-supported trainers, so I wonder if they have dropped it.

There is another thread on the Forum regarding a different trainer that is no longer working with Zwift that seems to have stopped functioning with the same update. It almost seems like there are some devices that the manufacturer had set up the firmware so that it would work with Zwift, but then Zwift changed something and the trainer no longer works - perhaps until the trainer manufacturer does another update. Not at all sure on this, of course, but I suppose it’s possible.


Thanks for the comment - and I noticed that too when I checked that list of Zwift-supported trainers. I think the best way for me to determine this is to find another user of these rollers that also uses the Apple TV interface.


FWIW: Here is the thread with the other unsupported device noted as no longer working after the recent updates:

I’m sure there has to be others using the E-Motion rollers, question is whether or not they are here on the forum.

I would open a ticket with Zwift, but I would not count on them for a fix, much less a quick fix. Why? Well, it’s not on the list of supported devices. Even if it were, Zwift are slow to respond to issues involving the big/main trainers (e.g., Wahoo, Tacx, etc…), so imagine how slow they’ll be for a small percentage device.

Have you contacted InsideRide? They should be able to sort this out the quickest.

That said, I don’t understand how Zwift keeps breaking Bluetooth whether it be connectivity or functionality. For the former, it’s a protocol. For the latter, there are specifications which define the fields for data. Why are they monkeying w/this to the extent it breaks stuff?? Has Zwift been doing non-standard stuff (i.e., workarounds, hacks)? Then they “fix” themselves to the standard thus breaking stuff because the device manufacturers have had to be non-standard to work w/Zwift? Futhermore, QA at Zwift … Anyway, enough of my tangent.

Again, contact InsideRide, they’re your best option for some answers and/or a fix. If you can try some others like TR, Rouvy, etc., you could see if it’s a Zwift only issue.

There you go!


Hey I’ve been using the inside ride smart roller setup with Apple TV for a couple years. They’re working fine after the update- I did have to reconnect them as a controlled resistance sensor though.

My specific setup is a PowerTap power meter paired to the rollers via the InsideRide app, Inside Ride paired to Zwift as a power meter and controlled resistance.

Jesse - thanks for writing…

I took a few days off and tried again this morning. Still no luck. I have an Assioma power meter connected to the rollers, then the rollers to Zwift as power meter and controlled resistance, as you do. In ERG mode, as Zwift requests more resistance from the rollers, nothing happens, and the yellow MIN resistance light stays on. If I just do an open ride the MIN resistance light is on for grades 2% and below but once the grade goes to 3%, the MAX light goes on, until grade drops back below 3%. Its such odd behavior from a product that has been great for years.