Incomplete power numbers in Zwift Power from recent event

Typically, when I do a Zwift event my power numbers in the event as listed by Zwift Power are initially listed lower than actual for sometimes up to 6 hours. The giveaway is usually when I look at my power graph and it flatlines (usually at the shorter intervals), indicating there’s some data missing. This usually sorts itself out after 4-6 hours and all is well. Last night I did stage 3 of Tour of Makuri Islands and the save/upload of the event was buggy. The event does show in Zwift Power; however, 14hrs later my graph still flatlines at ~1-21 seconds. When can I expect my correct numbers to show in ZwiftPower? TIA

Once the race has pulled the .fit files from Zwift; indicated by a blue bolt in the avg column

Nearly everyone has a blue bolt except for me & a few others with a green bolt. Is there a reason this is historically slow for me? It’s never been this slow (18 hrs since event ended).

when did you move your Profile to Private ?

that is usually one of the main reasons.

I haven’t changed it recently. I’ve had it this way for a while. Thanks for the heads up, maybe I’ll loosen that up.

others have had similar issues recently. But this might not be the only reason. Give it a try.but Im not sure if it will definitely correct this ride.

others may come in with different suggestions.

Need to turn Activity Privacy to Public from Private or Followers.

Once you have made that ride Public; request a faster update and see if it pulls the .fit file.

The plot thickens as I investigated more. All of us with green checks have 1 thing in common…lag.

Any ideas what is contributing to lag? I have a H3 bluetooth to AppleTV and pretty decent wifi.

Tried the ‘request a faster update’ and had no impact. That’s usually my first go-to.

I am a bit worried about this lag issue as I will eventually start racing again and need everything working tip top by then. Since spring Zwift race season I even upgraded from an H2 trainer to an H3 as well as upgraded my ATV HD to a new 4k with faster processor, just to eliminate some gremlins I had racing last spring . (I’m using these Tour events to reset my numbers ahead of racing. Most of my prior numbers hit the 90 day expiration when I hit the outdoor season.)

Of those you list, only you have one event with live data with rest public. The vast majority have all their events private and 3 or 4 have a mix. Checking a couple of other events yields same result so lag is quite likely resultant of, rather than caused by.

If you’ve now changed your settings so Activities are public, I’d suggest you find a relatively quick and painless event in the schedule and test that new ones come through. No reason why they wont.

EDIT: you could also drop a request off to and see if they’ll hit the reset button for you (quote your the eventid and your ZP id). Used to be a time when we had an awesome ZP volunteer that helped us out in times like these but I dont see Zwift jumping in and doing that since they grabbed ZP.

1 Like

Thanks. I’ll give it a go on stage 4 tonight & see what happens. I am a bit puzzled that privacy settings suddenly became an issue as i haven’t touched those recently. Just to clarify, are you talking Strava privacy settings? I didn’t see anything in Zwift or Zwiftpower so im assuming you’re talking Strava. Thanks again for the troubleshooting.

1 Like

[quote=“Chris Barron [VCRT], post:12, topic:593984, username:onefastrph”]
Just to clarify, are you talking Strava privacy settings?

No, Zwift.

Companion App > Settings > Privacy > Activity Privacy = Public

Well, that one is already set public and not one I ever recall touching.

Could have accidently hit the Private button when saving, or even just Zwift being Zwift. Had one a couple of days ago where I did a u-turn for no reason whatsoever - never happened in 30,000km’s of playing the game. Sometimes the Zwift hamsters do weird s**t I’m afraid.

BTW, if you go into that activity in the Companion App and hit the pencil as if editing the event name, you also get to see what that activity is set to, and can change it …

This is what we see when we try to look at your Activity details.

Thanks for all your help. Saving that ride was glitchy so I’m betting that’s when i hit the privacy.

I double checked. I have the ride public. Only my profile is private & it has been forever.

So, just did stage 4. Riding strong 1-5 positions mostly. 4km from end i get spontaneously booted to AppleTV menu! Same happened on stage 3 but happened after the ride concluded. My buddy who i was riding with got booted 2km later. He’s on an iPad. Makes me think it might be an Apple thing. I’ll use my PC next event and see what happens.

[quote=“Chris Barron [VCRT], post:19, topic:593984, username:onefastrph”]
I have the ride public. Only my profile is private & it has been forever.

Yeah your Profile being private should be fine. If you dont mind, can you accept my request to follow - I just requested to follow you - I’ll bail once I’ve looked at that earlier activity. No prob if you are not comfortable. But I’m stumped.

You may have a couple of things on the go or one thing causing a few things. The below thread is one where Apple devices are crashing which relates to photos.

Crashes on PC’s too.

Hope your PC experience is better!