Hammer connectivity issues

Hi,
I’m experiencing connectivity issues with my Hammer currently. It only connects to a blinking blue dot but I never get a consistent blue dot on the Hammer. So I guess that this might be the reason why it doesn’t change resistance in Zwift? I never experience this when I connect my Hammer to my Zwift on Windows. It only appears when I connect it to my Huawei Mediapad M5. Both systems are uptodate. I also tried this idea: Cycleops magnus resistance
but I couldn’t solve the problem.
Would you have any ideas what I can do to control my trainer on my Mediapad as well?
Thanks in advance,
andrea

Maybe your Hammer is paired to another device? Blue blinking is the Hammer is connected to a Bluetooth device but is not being controlled. Solid is it’s being controlled. Have you got the Hammer paired as a controllable trainer on the pairing screen.

Hi Nigel,

thanks for your reply. The Hammer should only be paired to my Mediapad. It is connected as controllable trainer on the pairing screen as you can see in the pic attached.

Thanks in advance for your help!

Regards

Andrea

Probably time for a support ticket with Zwift.

I’ll give that a try and keep you posted about their reply. Thanks again!

Hello. I am experiencing the same issue with resistance on my Hammer. It works fine over Apple TV 4K, but the past 2 days I wanted to try the Android app on my Samsung Galaxy S9. Everything works and connects; it just doesn’t change the resistance.

Hi,

still same issue here but somebody from Zwift is already working on it and as soon as I’ll get some feedback, I’ll let you know.

Cheers from Austria,

andrea

Any update? I’m still having this issue with Hammer using Android on a Huawei Mediapad M5.

Me too. No update so far :frowning:

Same here not subscribing without this fixed.

I have the same issue with my h2, there is a connection but no resistance control. I found that this trainer is in the unsupported trainers list. No point to subscribe untill a solution for this.

Forwarding this info over, thanks for the heads up everyone!

strange when I log a ticket nobody at Zwift seems to know what we are talking about while the complaints are numerous and well responded in the forums… (for a while btw)

1 Like

Rode with my tablet again this morning, with the Zwift app having downloaded the latest update last night, and still no resistance on the H2.
Today it didn’t matter at least, as I wanted a very easy ride anyway. Still, not ideal - this is not a new issue.

So no solution indeed. Even no feedback. Great quality for 15 euro a month…

I’ve been assuming they’ve been working on it due to this language in the Play store:

One last thing - we’re aware of some major outstanding issues, and we’re actively working to resolve them. In approximate order of priority, they include:

  • Spin-downs don’t work
  • Trainer Erg & Sim mode don’t work on CycleOps Hammer trainers

As much as it breaks my heart, because I love Zwift, I think I’m going to have to cancel my subscription. The thousand dollars for a trainer that works with other software trumps paying to be a beta tester for software that doesn’t work.

I still love ya Zwift, it just doesn’t make any sense to pay for beta software that doesn’t work with the top-end trainers.

FYI @Vincent_Williams1

1 Like

Just another bump to this. This issue is stopping me trying, and potentially subscribing to Zwift. I don’t really care about spin downs (i’ll do them in Rouvy), but I’m not ponying up without Zwift controlling the resistance of my Hammer.

1 Like

Micah - so why use the Android version of Zwift? Zwift works fine for me running it on my PC with my Hammer trainer. The Android version is after all still in Beta. That said spindowns don’t work properly with the PC version.

Depending on your ‘pain cave’ setup, a tablet can be much more convenient than a PC?

My trainer is set up in the lounge, and while Zwift looks better on my old PC, once Zwift (hopefully soon) controls my H2 correctly, I’ll switch to using my Mi Pad 4 on a custom stand. Neater, easier to move out of the way.
If I had an extra room to spare, PC all the way, with a nice big screen :slight_smile:

Hi, I had this problem also. I had ANT+ and built-in BLE enabled (ANT+ for a HRM and cadence sensor) and noticed that Zwift would connect to the Power Source via BLE but used ANT+ for the Controllable.

I noticed there were two different approaches fixing this:

  1. After everything was paired and I was getting the flashing blue LED, I would manually select the BLE connection on the “Controllable” icon;

  2. After everything was paired and I was getting the flashing blue LED, I would click on the wrench icon new the Power Source to invoke the calibration screen and immediately cancel out of that screen (i.e. I didn’t actually do the calibration).

I know you didn’t mention also having ANT+ enabled but maybe option two (clicking on the wrench) will do it. That seems to trick Zwift or the trainer into being in “controlled” mode.

Actually there was a third method if you do have ANT+ enabled and that’s to pair the trainer without the ANT+ enabled then plug in the ANT+ dongle to pair the HRM and cadence sensor.

Hope this helps. I did and entire ride without noticing the flashing blue LED and was completely confused by the lack of gradient changes.