Cycleops magnus resistance


(Martin T) #1

Hi,

I’ve been trying the android app with a cycleops magnus (using pixel c tablet, looks lovely!). Everything pairs correctly using BLE but in-game hills in a free ride don’t seem to effect the resistance - though in game speed drops, and similarly erg mode in a workout seems not to be doing anything to the resistance of the trainer. The Magnus does pair as a ‘controllable trainer’ in the android app pairing screen, and cadence and power are being reported successfully, it just seems to be an issue with resistance control. Everything works fine when using ant+ on pc so I’m sure it’s not the trainer.

Cheers


(Vincent W.) #2

Thanks for the heads up Martin! Were you able to troubleshoot the ANT + connection using this guide? https://support.zwift.com/en_us/my-ant-signal-is-dropping-running--SktF2_orX


(Martin T) #3

Hi Vincent,

As I said, the ant+ connection is working fine. That’s not the problem I am reporting.

The issue I’m having seems to be specifically with BLE control of the resistance of the trainer (cycleops magnus) on the android beta. Everything else (power reading, cadence reading etc.) seems to be working fine over BLE on android.

Cheers,

Martin


(Martin T) #4

Hi again,

Just to update you, I’ve downloaded the latest version of the zwift android app (1.0.30587) to my pixel c tablet and there’s no change to this issue i.e. Zwift is not adjusting the resistance of the cyclops magnus over BLE despite it being connected as a controllable trainer and getting all the power /cadence data fine.

I’ve had the chance to also try it out on a pixel xl and exactly the same thing happens there. Zwift runs fine, connects with the magnus but doesn’t adjust resistance.

I’ve also used the Rouvy android app connecting over BLE and there, everything works fine; controlling the resistance and reading all the power data - so I’m absolutely sure the issue is with zwift, not the trainer or the BLE connection to the device.

Not sure if it’s worth adding but I did notice Rouvy was also perfectly happy connecting to the magnus over ANT+ via a USB otg cable and a standard Ant+stick, which isn’t something the zwift android app is offering yet. Maybe that’s something for the future.

Cheers again for your progress on this.


(Christopher Constant) #5

I as well have a Cycleops M2 and Zwift android beta will not adjust the resistance. Power/cadence and all information shows correctly but it will not adjust resistance. Works fine if I use the Zwift companion app and my computer, but not when I run the stand alone Zwift beta.


Hammer connectivity issues
(Renzo Castro) #6

I’m having the same issue. CycleOps Magnus and an LG G6 phone with Android 7.0. Workouts and freeride don’t affect the resistance on the trainer, despite pairing as controllable. It reads power, but the App is not controlling the resistance.

I’m emailing with support, providing log files, and I’ll try a few instructions they gave me, but I don’t think that will solve the issue. In case it helps anyone, here’s what they sent me:


Thanks for writing us.

The way you’re explaining the drop in resistance, it kinda sounds like it could be Bluetooth interference, but I’d need to take a look through your logs to be sure. If you have your Magnus paired in any other training apps or through Android’s Bluetooth settings, either could prevent data from making it from Zwift to your trainer.

When you have a moment, please restart Zwift and tap the logo on our title screen three times. You should be taken to a new screen showing two columns. Please highlight all of the files in the left column and email them to us at logs@zwift.com. Please let me know here once you’ve sent them in as I’m not automatically notified.

Afterward, please log out and exit Zwift, then go into your Android settings, turn off Bluetooth, then power off your phone. Let it shut off for a minute or two, then turn it back on and re-enable Bluetooth from your Android settings once more. If you’re still noticing problems with resistance afterward, please ensure ERG is properly enabled/disabled and if that doesn’t help, I’d suggest unpairing your Magnus from Zwift’s Paired Devices screen, exiting our app, and completing an official calibration in CycleOps official support app. You’ll likely need to unpair your Magnus from their app before pairing it with Zwift again though.

Please let me know how that works out!

Ride On!


(Andre Turner Jr) #7

Did anyone try unpairing their Magnus, did this work?


(Martin T) #8

Hi,

Just another note on this. Still no change after latest app update (1.0.31443), magnus still connects as ‘controllable’ fine via Bluetooth, all power and cadence data is reported fine, but zwift is not altering the resistance in erg mode or on inclines in free rides.

I’ve tried the off-and-on suggested above and that’s not made any difference.

Cheers,

M


(Keith D) #9

Can confirm, Cycleops M2 variable resistance not working on Android. Works fine on Rouvy.

Immediately works when pairing same M2 to IPad.

Zwift Android V26-1.0.31443 on Galaxy Note 9


(Eric Larson) #10

Can also confirm that zwift does not adjust resistance on cycleops M2. Pairs up fine via BLE, but resistance never changes. Works just fine with rouvy app and with zwift app on pc.


(Keith D) #11

To piggyback a bit on the thread, I sent some log files into support, did a quick in and out on the steep tunneling London, no change in resistance whatsoever.


(Michael Tucker) #12

I’m having the same problem using a Cyclops Magnus with Samsung Tab S4. The trainer connects, shows as controllable and reports power but the resistance doesn’t change. Has anyone had any luck since the last post?


(Michael Tucker) #13

@Vincent Is there any update on this issue? I have submitted a support ticket as there has been no solution suggested.


(Michael Tucker) #14

@Vincent You’ve acknowledged there is a problem with resistance control on the Tacx Neo that is being worked on in this thread: ERG mode with Tacx Neo don't work with last update . Can you confirm whether this is the same issue affecting the Cycleops Magnus and will this also be fixed?


(Vincent W.) #15

Hey Michael I’m looking into it with the Android development team. I will get some kind of answer as soon as I can!

In the meantime can you shutting off Zwift, unpairing your Magnus from your phone entirely and unplug it. Then launch Zwift again and at the pairing screen plug your Magnus back in. Try pairing for power and controllable again and see if that helps!


(Hansi Lazarus (ZRG)) #16

Same here with my Tab S2 and my Tacx Smart Flow… It worked well, and then the last Update came… :cry:


(Keith D) #17

Did these steps on mine, and no change. It pairs fine but zero change in resistances. (M2)


(Matt Phillips) #18

Have a CycleOps hammer and it’s the same thing. Everything pairs fine through Bluetooth but the app doesn’t control the resistance based upon elevation.

This works in my rouvy subscription just fine.

Pixel C tablet


(Fullof Corn 🌽) #19

I would love an update on this. I’ve been racking my brain and doing all the updates & suggestions. Just like the others I have no resistance using Zwift. Rouvy, BKool and others work fine. I receive all the data within Zwift but the resistance doesn’t change and I cannot get the spin down to calibrate. I’m using the Cyclops Magnus with S9, but it also doesn’t work using LGG6 either. I wish using the ANT+ service within the S9 was an option. That may solve the problem. I have only 1 more week free trial left and hope a solution comes before that so I can justify the cost.


(Vincent W.) #20

For everyone who is experiencing issues with Cycleops resistance can you provide your:

Exact trainer
Device running Zwift
Game version
Trainer firmware version

This will help a lot! Thank you :ride_on: