Hammer bluetooth NOT working to control power; ANT does work

Within the last 24 hours, the trusty Hammer lost its ability to be controlled by Zwift (in bluetooth mode). I naturally assumed it was Hammer’s fault. As others have experienced, it would “spin out” and was unresponsive to any trainer difficulty setting (1% to 100%).

I then read a variety of forum commentaries (most of which cited Hammer as the culprit). Rather than box it up – I tested an alternative control source > a Wahoo Bolt < which controlled Hammer via its difficulty settings (on the Bolt unit itself, not the trainer difficulty setting in Zwift) and through wattage settings. Again, both of these in bluetooth mode.

Hoping to find a solution, I re-visited the forums only to learn that Hammer was “blamed” in roughly 90% of the commentaries with regard to the bluetooth / not controllable issue.

Just before I began to box up Hammer for a return trip to our Cycleops friends, I borrowed the ANT connector from my wife’s Cycleops/F3 ride … and viola > Hammer power was controlled in Zwift. What’s up with that!?

Summary of action steps taken:

  1. Reset Hammer multiple times to verify connection
  2. Attempted to calibrate Hammer (waste of time > the forums are correct)
  3. Verified that Cycleops firmware was current
  4. Connected Wahoo Bolt and was able to control Hammer power in bluetooth mode
  5. Checked to affirm that no other devices were “accidentally” connecting to Hammer (none found)
  6. Initiated an ANT connection and it was able to control power within Zwift (tested live in Watopia)

So, rather than “box up Hammer” as many other people have done, I elected to purchase a second ANT connector (arriving on 4/22).

For those that haven’t tried the ANT solution, it worked for me.
I’m running IOS > MacBook pro/iPad pro both with Mojave. And Hammer is located 2’ from the computer and/or iPad.

Zwift > please address this issue within QA.