Getting re-routed off course on routes during group rides and meet-ups

Hi, since the new zwift update this week 6 June '23, I’ve had issues with being re-routed off course on group rides and meet-ups. Was taken off course 3 times on one group ride and tried 3 times late joining but to no avail.
In particular on The Muckle Yin route I’m having issues with being re-routed. Happened both in two meet-ups and a group ride. Instead of going up the two koms and doing the Breakaway Brae I am taken past both the Sgurr Summit North and South KOMS and instead of doing the Breakaway Brea Reverse and the Breakaway Brea… I am doing only the Breakaway Brae Reverse twice. It seems I’m stuck on the Loch Reverse Loop. I am doing the FRR race series and The Muckle Yin will be the route raced this Friday & Saturday. I have no confidence that I won’t be re-routed off course during the race! This is most deffinately a zwift bug and very frustrating and inconvenient.

Can Zwift please fix this bug before Thursday so that I can at least ride one reckon ride properly. Thank you.


Welcome to the forum.

What device are you using to run Zwift and on what version are you currently?

1 Like

We had this issue on Beach Island Loop on the Giant Sunday ride this past Sunday.

I feel like it wasn’t happening quite as much through March and April.

But this late join going down the wrong route bug is definitely still around.

User was on PC.

Route starts downtown Watopia on the pier, spins you counterclockwise around the Volcano from north bridge to south bridge; rider ended up having to rejoin… for a second time, after their game decided to route them INTO the Volcano on the southern side, as if they were doing Volcano Reverse Circuit.

1 Like

Hi Gerrie. I use apple tv (version 1.41.0) and link via blue tooth to my wahoo kickr smart trainer. Wifi. No VPN used. I’ve tried twice now to delete zwift on my apple tv and re-install. Also, of course did the manual check several times for an update but non showed. My Apple tv is set for auto update as well and it didn’t prompt me to sign in from Sunday/Mondays update. Only asked me to sign in when I reinstalled.
I have now swopped my apple tv with another (slightly older one of mine that I’ve kept as a back-up) and did a 40km group ride in Makuri today and have not been re-routed off course during that ride… but someone else was taken off course. There is deffinately a bug around affecting this issue.
I hope I’ve provided enough info.

Also when I tried to join a bot ride I was placed near the bot but going the opposite direction. Thought I’d just put that out there too.

Hi Andrew, I had that issue on Monday. Tried to do a DIRT group ride (Makuri) and was re-routed off course three times. Tried three times to late join but to no avail… I was simply re-routed off course again and again and again… gave up on the third try to late join. Then tried to join a bot ride but was spawned no where near where the D bot rider was (couldn’t see the bot rider anywhere…not even on the mini map top right).
Very frustrating Monday on Zwift. Tuesday had the crazy issue with The Muckle Yin (as I posted earlier)… so another frustrating attempt at zwifting. Two times I set myself a meet-up…both times I was re-routed. Tried a DIRT group ride later that day on the same course and same thing happened. Really frustrating experience.

I’ve also had lots of issues joining pacer bots on iPad since the latest update. They sound similar to what is being described with group ride problems. Takes 2-3 attempts to join, it’ll place you on the route but nowhere near the robopacer. Joined Jacque last night and it put me +1:50 ahead of the group. I was able to join by just slow rolling since that seemed easier than trying to rejoin multiple times to get it to work.

This is a consistent problem every time I’ve tried to ride since the latest update.

For what it’s worth I did notice that the new timed ghost (best person on the route) doesn’t even stay on course for Jacque on Volcano flats. Not sure if that’s at all related.

The joining Pace Partner issue will be fixed in 1.42.

True, i was 4 minutes behind the group. However on a 3R endurance ride today several of us where sent in a different direction off route… didnt really matter to me (could still see the leader board and chat so i felt i was still with the ride) but thought you should know

We’ve had a few late joiners re-routed during Pride rides in the last few days.

Same issue for the past 2 weeks with not being anywhere near the bot when joining a bot ride. I’m using ATV but my son has the same problem and he is on a PC.

BTW, when is 1.42 releasing for ATV?

Over the next two days

I was on a Cycle Nation ride and was routed off course twice! I couldn’t rejoin after the 2nd screw up. What’s with all these bugs? Fix them please.

I was on the Zwift Ride Series Coastal Cruise 45 minute ride this morning and my Avatar took a wrong turn from the group and was riding in the middle of a field. I logged out and back in and was placed back in the group and at the next intersection, went the wrong direction again. Rinse and repeat a third time, and the same effect. So I rode out the 45 minutes solo, actually on a continuous smaller loop. I could see the other riders coming the other way once, but was not able to U turn to join up (I’m guessing it would have made no difference). Is this related to the Not being Able to Join a Robo Bug that will be fixed this week, as I’ve had that problem twice as well

If this continues to happens to anyone on 1.42 please let me know and I’ll flag with the team.

It happened to me during my ride yesterday and today. It always seems to come in at the end of my training rides. Yesterday about 40 mins in and today about 50 mins in. Today’s ride was on TicToc.

Are you on 1.41 or 1.42?


It states Game Version 1.42.0 (113138). I also just checked and it says Zwift is up to date.

1 Like

Just so I can follow up on this in case I see it myself in the coming time, what kind of details are you looking for specifically or need to know; ie, route, what group ride / robo partner, device.

Anything else to keep an eye out for?

Noticed it happen to someone again the other night, but holding reserve until 1.42 is out for everyone.

Still haven’t had it happen to myself specifically (I’ve only had to rejoin a ride once or twice though). But I still hate telling people to rejoin our group rides, only to see them veer off into the nether immediately after.