Garmin speed sensor issue

Hi,

I am new to Zwift (only successfully connected twice!) my speed sensor keeps connecting to the Bluetooth on my phone instead of Zwift and there is no ‘i’ to forget the device. Has anyone had the same issue? Or ideas how to resolve? Picture below shows what I see

I should probably point out I’ve tried the following:

  1. Resetting the network
  2. Restarting in safe mode
  3. Deleting the app and reinstalling

Any help would be grateful!

What device is that?

If you click on the CAD-BLE device doesn’t it give you a option to forget.

Hey,
It’s a Garmin - nothing comes up when I hit either the speed or the cadence.

Try this:

image

Thanks for the suggestion Gerrie - I have already tried this multiple times nothing happens when I click like that on cadence or speed, the screen remains the same

Have you tried to turn off Bluetooth on your phone and see if that works.

Bluetooth can only pair with one device at a time, and if it is paired with the phone it wont be able to pair with Zwift.

I understand that and believe that’s where my problem lies - that the sensors are connecting to my phone before Zwift. However, I am using my phone to use Zwift and therefore cannot turn off Bluetooth

I have asked around so some advice.

You might want to make sure you is out of range of the sensors so they don’t connect and then try and forget the sensors.

Here is a link that could help: https://osxdaily.com/2019/03/09/how-remove-bluetooth-device-ios/

1 Like

Wait, the phone is your zwift device and the sensor is pairing to your phone but like the wrong part of your phone?

Are you running zwift on your phone or using the companion app?

Maybe we should start here: Guide to Getting Useful Support

2 Likes