Garmin Speed and Cadence Sensor 2 problems

Hi,

I am new to Zwift and have a paid membership. I have been searching for answers on this forum and on reddit with no real answers. I have also sent an email to Zwift and tried calling them without any response. Here goes…

I am using a Kurt Kinetic Road trainer (dumb trainer) with brand new Garmin speed and cadence 2 sensors. I was able to easily connect and pair both sensors to Zwift. However, every time I try using Zwift, the cadence sensor reports accurate RPMs but the speed sensor does not transmit data and my speed is 0 mph. My avatar refuses to move. How can I fix this?

Battery is brand new on speed sensor. I have tried unpairing and re-pairing several times with no change. I have tried using Zwift on my Mac and on my iPhone and it has the same results. No speed data transmitted and my avatar does not move.

Can you test the the speed sensor is working by pairing it to your garmin or some other device to see if the sensor works properly and that the sensor is set up correctly?

What does your pairing screen look like on zwift? Can you attach a photo, maybe someone can see something obvious.

Hi,

I am able to connect it to my garmin connect app (see attached pic). I am attaching the other pics I took of my laptop showing how it is paired.





1 Like

Hmm these pictures suggest you have connected to the trainer itself rather than your new garmin speed sensor. Unpair from the garmin app (from memory a Bluetooth sensor can only be connected to one thing at a time) and try to select the speed sensor from the menu (the pairing screen picture says you are connected to the kenetic).

By the way, when I suggested testing the sensor by connecting to your garmin I meant a garmin headunit (if you have one) a sensor could theoretically pair properly but doesnt working properly and doesn’t calculate or transmit the speed data (so it could connect but not transmit speed). If you connected to something like a garmin headunit and pedalled and it came up with some speed (eg 20 mph) then you’d know the garmin sensor is working correctly.

Also in the pictures you seem to have 1 or 2 mph not 0 for some reason.

Will try your suggestion and unpair from the IOS garmin app and see what happens. The Kinetic is only a dumb trainer with the speed and cadence sensors. Unfortunately, I do not have a Garmin head unit to test that out. Yes I did notice that too about the speed. Before it was only showing 0 mph. When I was taking the pics, it showed a speed of 1 -2 mph but the avatar would not move. The cadence sensor showed about 85 - 90 RPMs at the time.

Thanks for the suggestions.

No luck. I unlinked the speed sensor from the IOS Garmin app and unpaired and re-paired to Zwift. My avatar moved very slowly to 4mph and then stopped and refused to move again.

Bump. Hopeful someone has other suggestions. Sent an email when in trial membership and another one after I paid and I also called with no response from Zwift. I disconnected the cadence and speed sensor 2 from the Garmin connect app and connected them only to Zwift, but still having the issue that my avatar does not move. I don’t know if this is a problem with the Garmin bluetooth connection or with Zwift. I see other posts with similar issues as mine with no solution.

Hi,
I’m having similar problem. I’m using an iPhone X.
I’ve tried connecting the sensors using Zwift in the iPad instead, and they worked fine. My iPad is an old mini 2. I tried CycleMeter in the iPad and it works fine as well. CycleMeter on the iPhone X doesn’t show the speed also. Only the cadence. My guess is something related with my phone.

1 Like

Or perhaps the iOS 13. My iPad mini is on iOS 12.

Hi

Same problem here.
My setup: “dumb” trainer (Elite Volare MAG Force) with Garmin 2 Speed and cadence sensors; Polar H10 hear rate sensor; Huawei Mediapad M5 Lite running Zwitf; Huawei Smartphone running Companion.

Your problem is that only the last sensor you connect to Zwift will be the sensor will work on the avatar movement.
This is how I tried:

  • Start Zwift
  • Connect Speed Sensor and choose trainer model
  • Connect cadence sensor.

In this situation yo will be able to see both sensors “connected” in the initial window, but only cadence will show cadence data, speed sensor will show “no data received” although it will appear “connected”.

Then try the opposite:

  • Start Zwift
  • Connect cadence sensor.
  • Connect Speed Sensor and choose trainer model

In this situation yo will be able to see both sensors “connected” in the initial window, but only speed will show cadence data, cadence sensor will show “no data received” although it will appear “connected”.

So, I allways start Zwitf in this second mode.
In the other hand, heart rate monitor is detected and connected without problem and shows heartrate correctly.

Then, when I’m “zwifting” and my avatar is moving, I can see speed (so Power too) and heartrate, but cadence shows “–” although is connected.
At the same moment, in Companion App I can see cadence data, but incorrect data: shows 60 or 64rpm constant, but I’m pedalling for example at 90 or 95.
In this same moment, in my Polar M460 or Suunto Spartan, I can see cadence data correctly.

The problem seems that Zwitf can only receive data from one of the Garmin sensors at the same time.

PD: if I try the same configuration in other training App all the sensors work without problem, so I think is Zwitf problem or limitation.

Hope it helps.

1 Like

Thanks for the response Juanjo. I will try and see if it works

same issue here just started tonight. all working fine for 2-weeks then “connected - no signal”
brand new Gamrin speed and cadence sensors…connect fine with Garmin 520. stopped connecting with iPhone 7 all updated and worked fine until tonight. no bike location or device changes. no bluetooth connections with any other devices. frustrating

1 Like

So far no useful recommendations when I finally heard back from Zwift support after several emails. I have also tried the above recommendations with no solution.

Setup:
Mountain Bike with 26 x 2.0 tires on a Kurt Kinetic Road Machine Fluid 2 trainer (dumb trainer).

I have tried so far:
1)Garmin Speed and Cadence Sensor 2 with BTE and my Mac.
-no issues pairing but 0 speed and avatar does not move.
-tried the above recommendation and connect cadence first, then speed sensor - did not work
-tried connecting only the speed sensor - did not work
-made sure sensors weren’t connected to anything else with BTE - still did not work

2)Bought brand new Wahoo Speed and a separate Wahoo Cadence sensor
-I thought it may be a Garmin problem. It’s not. Same issues as above with Garmin apply to the Wahoo sensors.

3)Bought an ANT+ key and USB long connection cable to place it near back wheel
-easy pairing again with both sensors, avatar did not move
-paired only speed sensor, still did not work

All 3 ways I get RPMs with cadence. Only one time I was able to move for 5 seconds and then stopped and avatar did not move. I can use the wahoo sensors and wahoo fitness app on my iPhone with no problems. The sensors work.

I have lots many hours trying unsuccessfully to use this program but I am about to give up and cancel the membership I have never used.

This is exactly the same as what I am experiencing, I only have the garmin speed sensor running, I have tried everything as well. It works fine though when going through iPhone it’s the iPad it refuses to work with. I had it running well for about 2 weeks and then seemingly around update time it has suddenly gone completely wrong and refuses to work. I so hope this gets sorted soon. I cannot use IPhone as need glasses to see that and cannot cycle like mad and get sweaty and expect glasses to stay on face. Please Zwift solve this problem

Also exact same issue as described here - tried all the fixes suggested - sensors work on garmin watch so are fine but not on zwift (same on sufferfest). Very frustrating. Is this a garmin issue or app issue?

Im having the same issue with my Garmin Speed and Cadence sensor. Everything was working fine before update 1.0.49617. I’m about to cancel my membership because no one at Zwift seems to have a solution.

I sent 3 emails to support after they answered only once basically just giving me a link to their FAQs which was no help. They asked me to only pair the speed sensor and not the cadence sensor. I tried that and it did not work. Never heard back from them again. I gave up and cancelled.

I’m having the same problem as many on here (and on other forums I’ve seen). Garmin cadence 2 sensor connects fine and shows numbers. Speed sensor 2 connects but shows ‘no signal‘ and 0 speed. It works with other systems so this is definitely a Zwift problem. Can someone provide a fix that actually works?!!

Hi…I had the same problems so was just using the speed sensor. It was supposed to be fixed in the last update which I downloaded today but is now worse as it won’t sync with the speed sensor, only the cadence sensor so the speed data is wrong, anyone else got this?

hola, yo tengo el mismo problema, el sensor en el zwift anda a 60rpm, antes andaba todo bien a 90 RPM pero ahora no me lee el sensor que se llama CAD.
que puedo hacer?

1 Like