Garmin Speed and Cadence Sensor 2 - Pairing Issue

I have the Garmin Speed and Cadence Sensor 2 (bluetooth and Ant+ capable) and I’m able to pair both sensors but only one can receive a signal and transmit data at a time. If I connect the cadence sensor it will start to transmit the cadence to the Zwift app (Android Samsung 9+) but as soon as I pair the speed sensor the cadence sensor stops transmitting data to the Zwift app and the speed sensor begins to transmit data to the app. At this point both sensors are showing that they are paired but the cadence sensor indicates it is not receiving a signal. The same scenario occurs if you pair the speed sensor first and then pair the cadence sensor. Any help would be appreciated.

Note in the picture below it shows the ANT icon is active. The above scenario is the same if ANT hasn’t been activated.

I have the exact same issue! I have an android lgv30.

I have the exact same issue! Whit 2 gemini 210 speed and cadence sensor.
Ride in pc and blutooh sensor in companion

I have the same issue. Using Garmin Speed & Cadence Sensor 2. I hope Zwift can fix the issue on this as there are very limited available stores that sell right now due to Covid-19.

I think the issue is the speed sensor is smart, and when they are both running the cadence gives its data to the speed sensor instead of transmitting it broadly.

My workaround is I only use my speed sensor in zwift. My garmin watch is able to pick up speed/cadence in addition, I just monitor my cadence via watch. Not ideal but it’s a way to get cadence for training.

Hi mate, i tried ridding on zwift using only the speed sensor as you said but i dont move that much even if i pedal fast and increase my resistance. By the way i’m just using a standard minoura b60 trainer. Also i noticed that the zPower is not available as option only tje classic ones.

Sometimes I have to play around with the pairing, like when I add speed the cadence will connect too. If I turn the cadence off quickly it’s normally not an issue. But sometimes it takes a few minutes to get everything working right. I’m also on a dumb trainer at the moment :slight_smile:

Hello! I have garmin speed and cadence sensors, but ant+ only. But since my trainer (smart tacx) can already provide the information, I use only the cadence sensor, because it is more accurate than my trainer. BUT, there is something strange, when I use my headphones instead or the sound of my computer, that is, if the computer is set with headphones (bluetooth) before I pair my sensors with zwify, it always result in my cadence sensor not connecting. My guess is that when there is too much going on with too many bluetooth and ant+ items, it gets mixed up. Maybe it is what’s happening for you?

I’m also having this same issue. They wont both stay connected at the same time. I reached out to the support team. Anyone have luck getting this fixed or find a workaround apart from pairing to a watch?

UPDATE: I had an old iPhone and tried pairing both to the App for iOS and had no issues. I think this might be a Zwift link to Android issue.

Hello, I’m having a similar issue, I only have the speed sensor but after pairing I see both speed and cadence sensor as connected, but both say no signal.
I am connecting via BLE on windows 10.

Same issue. New user. Waited anxiously for my speed sensor. Now I get in the game and I’m going 4-5mph. Frustrating. And no replies from anyone at Zwift? This thread was opened Jan 3rd?

Hi @Kevin_Albright

Tell us a bit more about your setup, how do you pair what device do you use to zwiftm
What trainer are you using.

Garmin Speed Sensor 2 with Cadence sensor. Trainer is an old Cycleops Fluid. Not a smart trainer. I have tried removing the Cadence sea air and same problem. Very slow speed. No matter how hard or fast I pedal.

1 Like

Hi @Kevin_Albright, what do you run the Zwift game on, Windows 10, iPad, etc? It sounds like you are getting some reading of watts, when you choose the fluid trainer does it give you an option of wheel size, if so what size wheel are you choosing? What type of bike are you using on the trainer, are you using a trainer tire, how much air pressure in the tire, how many times around the dial are you tightening the fluid trainer to the back wheel? Sorry, lots of questions!

1 Like

Running on an IPad. I have a road bike on a fluid trainer. 700x32 wheels. All working well. Have been using this setup prior to using Zwift. No slippage. Not a training tire, but using a continental gator. It’s an older pre-saris cycleops fluid trainer. I am getting watts, but they do appear to be low as well.

Is this uphill? How many watts are you producing, can you post a screenshot?

I could fix it, I had to pair the garmin speed sensor with Zwift companion as bridge.
I did these steps:

  1. Pair the speed sensor with the Android phone (Bluetooth)
  2. Login to Zwift Companion
  3. Login to Zwift on the PC
  4. Wait for game in Zwift Companion
  5. Select “Use Zwift Companion” from the little gear in the upper right corner
  6. Start pairing
  7. Ride On …

This will pair both speed and cadence sensor, the cadence is wrong, which is normal as I don’t have a Bluetooth cadence sensor, but I can disconnect it. The speed sensor works anyway.

I hope it will be useful

I will give that a shot. Thank you!

Not sure if anyone can help, past 2 weeks having this issue - rider slows down or stops.
I have a Wahoo Kickr, Samsung Android for Zwift companion. I have a garmin cadence sensor - its not showing up as paired but I didn’t think this was a problem since the Wahoo Kickr is paired and showing up, use an ANT - any suggestions - reached out to support and NO ANSWER other than generic email of they are “overwhelmed”.
Thank you.

Hello @Poh_Willson, the Kickr estimates your cadence so you dont need the Garmin sensor. Sounds like you are getting some interference in your ANT signal. Drop a recent log file into and see how your signal is doing.

Also, make sure you are using the FE-C option when pairing the kickr.