Cadence is not working properly

Too many posts about this crap cadence not working. Why isn’t this getting fixed. Renders Zwift unusable. I want my money back.
pissed

What are you using for cadence?

Wahoo cadence,wahoo speed,wahoo heart
Everything has been great for 2 months. Yesterday I was forced into a automatic update and it hasn’t worked since. (Zwift update)

Only the heart monitor stays consistent now. Cadence bounces from 171 to 0 and eventually drops out completely along with speed sensor

Bluetooth on laptop… sits on the handle bars., It’s been working great but now nothing.

Paul,

Thanks for responding. Sorry for the rants

Tony

2 Likes

Have you tried changing the battery in the Wahoo S/C?
Do you see the same erratic reading swhen using the Wahoo app?

I have the same wahoo setup and have never had accurate cadence. Either is erratic like you’re experiencing or cadence drops when going up hill when my cadence is much higher - just not accurate and very frustrating.

This sounds like you may be experiencing Bluetooth dropouts, as Jeff had mentioned. Run through the steps in our Bluetooth interference article and if you are still having these sporadic readings, open a support conversation with us so we can take a look at your log files and get to the bottom of it.

The same problem here - Wahoo cadence sensor in Zwift shows wrong numbers (too low).

I honestly believe my sensor and its batteries are OK (both new) and NO BT dropouts, as I get correct numbers in Wahoo app and I can see the same (correct) values on my Garmin Edge (first is paired via BT, second via ANT+)

But while riding Zwift (either iPad Zwift companion app or Zwift for AppleTV4K) cadence info is NOT correct at all. Example - I see 85 rpm on my Garmin (which I guess is correct value) and in the same moment Zwift says my cadence is 50 or so … the difference changes - sometimes it’s bigger, sometimes those numbers are getting closer little bit … but basically, Zwift cadence values are nonsense.

5 Likes

I have this same problem - and I see by searching that it’s very common.
My setup - Wahoo Kickr and cadence sensor. It works fine in Zwift for general riding. Works fine also doing Sufferfest workouts. The only time it doesn’t work is in Zwift workouts. Then I get the same problem that others have noted; the cadence shown does not match at all. What it does do is simulate the rider and what grade he’s on; if he’s climbing it’ll drop to 50 or so, and on a downhill it’ll be over 90. Turn off the workout and ride regular Zwift and it’s instantly better.

There is something in Zwift workouts that is causing this issue. Any advice would be appreciated.
Again - my setup works accurately in Zwift riding, but not in Zwift workouts. It has been this way for the two or so years I’ve been on Zwift.

1 Like

The Bluetooth troubleshooting link does not work

2 Likes

I have the issue in rides. iPad app and wahoo speed and cadence sensors via Bluetooth. I think the speed sensor is giving unreliable data too.

Same problem for me on my brand new kickr set up. In Zwift FTP builder workouts the cadence bounces from 30s to over 170 without any change in actual rpm. Any new information about this?

2 Likes

Using Wahoo speed, cadence and HR. Having the same issue with cadence. Garmin shows 80, Zwift shows 50. If I spin out in lowest gear over 120, Zwift caps at 64. Using a fluid trainer so I was thinking the calculated wattage was also then estimating cadence and speed, but then what is the point of the sensor?

I’m experiencing the same issue. Cadence was showing correctly up until this week. I have done solo rides, workouts and Tour de Zwift and in all cases the cadence is very low, 40 to 64. Am use Bontrager duotrap, but I tried the Wahoo cadence and still experienced the same issue. I don’t think the Bontrager duotrap is problem since it has been working properly for over a year now. I am using Wahoo KICKR. LIke I said, the cadence just stopped working correctly this week.

UPDATE: Apparently if you have Wahoo Cadence and Speed, Zwift will assign the Speed sensor to Cadence if you let it. Zwift checked my logs and found that that is what happened in my case anyway. I let Zwift pair everything automatically and was shocked to discover it assigned SPEED to Cadence. I deleted the assigned Cadence sensor (SPEED) and re-paired to CADENCE and it works now.

6 Likes

Hi, I am new on Zwift, however my 820 edge is reading the correct cadence between 80 to 120 rpm, while swift cadence will resist not to exceed 65 rpm… Any idea :pray:?

3 Likes

Got the cadence and speed as part of the Bolt package. Cadence was unreliable/intermittent but after troubleshooting wahoo replaced with no questions. Replacement was equally useless so I gave up on it. Happy with the Bolt though. Hope they have a better alternative now.

Does anyone tried conecting the cadence sensor through ant?
My garmin sensor is only compatible through ant. I dont remember where i read it.
Through bluetooth conects but without signal.
The cadence that appears in game is “estimated”

I have the same problem.

1 Like

Same issue with Garmin… cadence sensor is less than a week old and connected via BT. The readings are erratic to say the least.
Issues faced during FTP and group rides. I have tried to re-pair the sensor but to no effect.

@T_De

Did you check the cadence sensor using your garmin cycling computer.