Garmin HRM-Dual “No Singal”Zwift/Rouvy/Wahoo

I’ve searched the forum and haven’t been able to fix the issue.
Trainer: Wahoo KickR latest gen
Garmin Edge 530
Garmin HRM-Dual
iPhone XS-updated with newest software

Programs: Zwift/Rouvy/Wahoo

HRM-Dual will “pair” with the above programs meaning it will find it and pair but no HR Data will come across. Zwift specifically states “no signal”. The others no additional information.

Steps taken:
-cleaned and changed battery in HR Strap
-wet strap to “jump start”
-tried Zwift on my wife’s iPhone XS and worked fine. HR monitor paired, connected with signal and data was obtained
-removed HRM from other sensors (Fenix 6S, Garmin Edge 530) so that BT would not be picked up by other devices.
-shut down phone, airplane mode, turned on/off Bluetooth etc
-Going crazy!

I’m at the 4-5 hour mark of research and trying to figure out the root cause. The solution was to use my wife’s phone and download Zwift and it worked. I haven’t tried Rouvy or Wahoo to see if it connects to them but frankly that is beside the point. It connects and obtains data from Garmin Fenix 6S and 530 head unit.

We don’t have any other iPads/tablets to try and see if it will work with them or not.

I’ve reached out to Garmin no response yet. All programs are up to date and currently running latest software.

Worked fine even connected to Edge and Zwift for roughly 2 weeks before this became an issue. I’ve removed the sensor (HR) from all other programs and still nothing. Hopefully someone from Zwift will reply.


Some have suggested you have to short the unit in the HRM prior to the new battery. I have never tried or done but Google it.

The HRM may be paired with something else…watch, iPad, PC whatever. But if it paired directly with phone…hmmm.

Signal just may be weak and, if the phone close, it was picked up.

One other try…leave the battery out for 30-60 minutes…give it time to completely drain.

Thanks Chris. That one I haven’t tried, I’ll give it a shot!

Thanks again!


Unfortunately that didn’t work either. New HR monitor on the way. I’m about done messing with it but maybe someone will pop on with an answer.

Meant to note that I deleted the app and reinstalled them as well.

Sometimes they just do not work. I have several of them saved after stopped working. I have gone back and grabbed one or two and they work again.

Who really understands electronics?