Game Update 1.23 - March 9th, 2022

I use Zwift as entertainment while doing TrainerRoad workouts. ANT+ for all the TrainerRoad pairing and Bluetooth pair my gen1 hammer trainer to zwift with controllable unchecked.

After the update, zwift is interfering with the trainer. Zwift is running on Apple TV and TrainerRoad is running on a dedicated mini pc. With both apps running the trainer would only do about 30 watts. Backed out of zwift and immediately it picked up the TrainerRoad power and operated normally. Fired zwift back up and power dropped back to 30 watts.

Worked fine before the update.

Thx,
Ron

I have the same problem. It has literally never updated cleanly since 2016. When updating has finished, after you click the let’s go button, there’s no progress indicator, so I’ve no idea what’s going on. It just keeps scrolling different pictures, but never starts the main app. Zwift update is comfortably the worst I’ve ever seen of any PC application.

2 Likes

Maybe it’s just a coincidence that I had Zwift internet issues for the first time ever on the same day I updated the game and companion apps. Perhaps I was a bit too quick to point the finger but I’m really disappointed that having a problem-free ride these days is a milestone event to celebrate.

That’s long been an issue.

You have to kill the app and run it again. Right Click the Z icon in the system tray and close it. Then run it again.

My setup has been like this from day 1.

1 Like

For anyone keeping up with my rambling about frame rates and load time being worse than expected for a while, overnight it’s been confirmed that a) everyone on PC is essentially already running the new UI, whether you actually see it or not, and b) there has been a specific bug with the new UI causing extremely low frame rates for some people, now addressed.

The latter confirms that there can be a relationship between the UI and performance, so I wonder if we’re all effectively running two UIs at the moment. That would very possibly explain the performance issues I’m seeing. And the timeline fits.

9 Likes

To back up Dave’s point, since January 18th I have experience a number of crashes forcing a completely PC reboot. Looking at the logs, it is a kernel-power critical event. Basically my CPU is now being stressed to the extent that it is crashing. Performance has degraded significantly (it was already terrible in terms of CPU usage efficiency, but now it’s even worse).

1 Like

anyone else has issues with this update and syncing data to apple health (via strava)? as normal workout with strava sync to apple health. all workouts done via zwift sync properly to strava - but they are not recognized in apple health anymore.

i already opened a ticket with strava too - but as i mentioned, when starting a workout directly in strava it works. only “imported” workouts from zwift do not sync.

SOLVED: not a zwift issue - Thanks for reaching out. We recently updated our Health Kit integration, which means only activities recorded directly with Strava (iPhone or Apple Watch app) will push to Apple Health. You will need to connect your 3rd party device directly to Apple Health moving forward or reach out to the 3rd party if an integration does not yet exist.

So when will Zwift enable writing data to Apple Health?

4 Likes

No UI issues on AnoTher specific deVice is all im saying…

2 Likes

I don’t always understand everything you say but your continued efforts to improve things is very much appreciated! :slight_smile:

2 Likes

I’ve done the latest system update on my iMac and downloaded the new update on Zwift, I’ve tried to open the App, it opens then when I click “Let’s Go” the Zwift App closes.

@Marie_Barton
That sounds similar to what is described in this recent thread: Zwift app not working on macOS 10.11

Are you running a macOS that is older than Sierra (10.12)? If so, you need to update the operating system to a more recent one. Anything before 10.12 is unable to run Zwift anymore.

Great investigative work Dave.

Whilst I’ve not had anything as detrimental as system crashes i had noticed a little bit of stuttering during a running activity.
Log file showed a plummeting frame rate in a non busy area of Watopia.

Your findings go some way to explain this.

2 Likes

Since the last update I´m having an issue regarding the trainning plan I was following(TT TUNE-UP). Now when I start the game the training plan window shows up, same as it used to be, but it wont offer the next session ,only the optional ones (future an past).
In order to do the corresponding session I have to click later, then go to the plan and pick the specific session intended for that day.
It happens both in my mac and in the zwift companion app in my android phone so I think this may be a bug due to this last update
Any help will be appreciated, thanks

I run Zwift on a MacBook Pro. Every time there is a game update— large or small — I have to delete Zwift and reinstall or Power Ups don’t work properly. Ugh!

Thx

Thanks for this update! I was going crazy trying to figure out why it wasn’t uploading to Apple Health.

1 Like

The latest “improvements” to training plans appear to have messed things up for a number of people. See Training program tells me to go back to previous week [March 2022] [v 1.23.0] [SOLVED]

1 Like

same here… it made me crazy… now i have to find a workaround to fill my circles :stuck_out_tongue_closed_eyes:

1 Like

Same here, SingleTrack Slayer workout. Prior to the March update, Starting a new day the workout automatically showed the next workout. Now, it reverts back to some other “optional” Sunday workouts that I didn’t do. I have to manually scroll to find the next workout. No major issue but I definitely preferred that way it was prior to this most recent update.

1 Like

So with this new update I can no longer use Zwift on the computer I purchased specifically for Zwift. I have not checked my laptop yet. I am assuming it will not work there either. At this time I do not have the ability to update my pc’s graphics capabilities. So my questions- how many other people are in my situation that will not be able to update their devices? And how do I go about cancelling my subscription?

Thanks- I think

Just posting here as well but the update on iPad appears to have categorized bike sounds under the Game Sound slider instead of 3d world. With 3d World Volume all the way down bike sounds are still audible. With Game sound off the bike noise is gone.