Fitbit Aria 2 weight Scale and Withings scale not syncing

Mr. Delport - I find it interesting that both Withings and Aria work only once after a disconnect and reconnect (previously known as unlink and relink). This leads one to hypothesize it’s a software issue on the Zwift side.

That is my thinking as well. It is probably something that changed in the recent update.

All - we’re looking into it. Thanks for continuing to raise the flag on this one.


Shuji! Thanks much for the response. We all hope it’s an easy one to fix. Cheers.

Thanks for the update and looking forward to the fix when you have it.

+1 on this problem also. My weight is not getting sent via the Withings connection in the zwift companion app. Have tried to remove and then reconnect but it doesn’t seem to have made any difference

1 Like

+1 for this. Also experiencing this issue.

+1 for me too

I’ve having the same issue with my Withings “smart” scale. It’s a pitty now I’m losing weight, that I can’t see automated to Zwift.

Any chances to be solved soon?

1 Like

It’s still on our to-do list.


+1 same issue

Syncing between Withings scale and Zwift is KO since a few weeks.
Works only once when you establish the connection between Zwift and Withings.
Can someone from Zwift deal with this issue and tell when it’s gonna be fixed ?

Everybody, if you have problems with cloud syncing, please report them to your device manufacturer as well. The more people complain, the better.

E.g. Strava does not currently get synced with Withings either, and I have that connection set up from the Healthmate app, because Strava is an official partner since the end of 2019.

1 Like

Reported to Withings as well, Strava and others. For what it’s worth, Training Peaks works well and quick. Withings recently changed API and upgraded the OAuth to 2.0. That’s when the issues started. Maybe that’ll be a good start.


I must say I miss the auto update from Withings.

It still woks perfectly with all my other devices, it is only Zwift that don’t get the data.

If you look up a bit you will see Shooj said they are working on it.


Let’s not forget the original poster and his problem with the Fitbit Aria 2 weight scale, not the Withings scale. Although his wife says he will soon need two scales to weigh himself given his high degree of unabridged weekend beer consumption, I suspect he still wants to get his Fitbit Aria 2 problem solved so he does not have to go out and buy a Withings scale just to get this functionality again. Just a little reminder. Cheers!

How about it Zwift? Any update on an ETA for this fix?

Still issue synching with Withings

Is there any update on this now it’s been a bug since the last update?

It’s on our to-do list, but it’s lower on that list because it doesn’t break the game, and those types of bugs get higher priority.;

We ask that you manually adjust your weight in your profile in the meantime. Sorry for the news, but we wanted to let you know why it’s not been done yet.