Elite Suito & TUO Spindown Speed Issue [BLE]

System: Windows 10. BLE. Zwift build 1.0.56270.

Trainer(s): Elite Suito and Elite TUO. (possibly other Elite models)

Issue: Spindown process (wrench icon) registers I’ve reached 37kph but never tells me to cost for the spindown process to complete. It tells me to keep spinning… A few searches indicate this is a common occurrence. Out of frustration I went well above the recommended 37kph to 55kph at which time Zwift asked me to coast and the spindown completed successfully.

Other information: While spinning indefinitely at 37kph the TUO (and Suito) report a wheel speed of 23-24kph over ANT+ (Garmin Edge). When I accelerate to the ‘Zwift’ 55km/h the trainer flywheel speed reached 34-36kph… the required speed for the calibration process to start.

My guess at the problem: Elite trainers require non standard wheel sizes for accurate speed measurements. The SUITO requires a wheel-size of 84mm, the TUO is 47mm. (the ZUMO is 167, the Diretos are 173) The full list is published here: Elite Trainer Wheel Size Info. I suspect the wheel-size information within Zwift is incorrect meaning Zwift will never receive an ‘ok to coast’ message from the trainer until the trainer itself has reached the required wheel speed.

Digging into the BLE FTMS documentation I think my guess is solid. Given the amount of people users reporting issues this it’d be great to see this addressed.

Happy to provide further information if required.

Thanks @Shane_Miller_GPLama

That is a well written analysis. I hope Zwift find this useful. :sunglasses:

I have been telling people to use the elite app for calibration.

1 Like

Great detail @Shane_Miller_GPLama :+1:

I have an Elite Tuo and I’m having problem with the cadence, I think it must be related to your problem.
Do you have a abnormally low cadence displaying on Zwift (between 60rpm and 70rpm) ?

2 Likes

Cadence on the TUO is calculated from the very small oscillations in flywheel speed. You have to be really smooth on the pedals for it to report ‘accurate’ cadence. No issues here with the TUO cadence over BLE to Windows 10 when compared to Power2Max and Assioma power meter cadence values.

This spindown issue is a different issue (which i had hoped would at least be acknowledged by now!)

1 Like

Thanks for your reply, I was hoping my message would bump your subject up a bit :wink:

2 Likes

Bump. Still a problem. Where should I submit bug reports? Honest question. This has been swinging in the wind without reply way too long.

1 Like

Hi there,

Just connected my Elite Tuo as a newbie to turbo and Zwift (lots of research - thank Shane) and there is still no wrench. Was hoping to calibrate within Zwift after I completed the onboarding route but will use the Elite app for now.

Thankfully I found this thread as I was beginning to wonder.I assume (hope) Zwift have disabled the ferature…? Any update on timescales etc?

Many thanks Rob

tenor

I had the same issue with Tuo (to be honest I also couldn’t calibrate it with myETraining), but thanks to your instructions I managed the calibration on Zwift. Indeed had to go up to 55+kph before I got the message that I could stop pedalling and then calibration finally succeeded after many attempts.

Don’t know if that is expected, but I also found that the Android app does not let me do the Tuo calibration (the wrench is not there in the Bluetooth screen), while the Windows version does.

Did you get anywhere with the cadence reading? Mine’s the same; always reports somewhere between 60-70 whilst the elemnt is showing 90+…
I’ve just upgraded the firmware and done a spin-down in the elite app (same issue as reported by Shane in zwift) so I’ll see how it is next time, but not holding out too much hope as the power seems way out on flats/downhill too… I’m pedalling squares at 130 watts on the flats but fine going uphill! Starting to suspect I may have a dud.

Ping… another check-in to bump this issue up the pile. I’ve had another handful of Elite trainer owners spin to 55kph to resolve this.

1 Like

Another Tuo owner here. Spindown worked after reaching 55kph, however cadence reading won’t go over 65rpm even though I’m clearly pedalling at 80+. Hopefully that’s an easy software fix. Power readings seem accurate, although I don’t have an external power meter to compare. Resistance changes feel realistic.

Quick update on my Tuo issues:
Did a firmware update in upgrado app (v1.6?) then a spin-down calibration in myEtraining (or whatever it’s called) - winner! Power reading is miles better, no longer pedalling squares at 1.5w/kg, and the cadence looks much better. Downside with the cadence is that it takes a while to register zero cadence now (much like my old Qubo did) but it’s only an issue if a I want to super-tuck in game.
Not tried the in-game spin-down but I can live with going back to the elite app when required.
TL;DR - If you’ve got an issue with cadence and spin-down/power, try the elite apps. It’s better than waiting for issues to get sorted within zwift.

Can confirm - firmware update from 193 to 194 using upgrado fixed the cadence issue.

2 Likes

I have just started using Zwift with my new Tuo, same issue. Cadence reading always sits at 60-70 when I’m definitely spinning faster - any advice?

Download the upgrado app and upgrade the firmware, takes about 10 minutes to do - mine’s been spot on since the upgrade :+1:t2:

1 Like

thanks buddy- think im good to go now- appreciated !