Elite Suito & TUO Spindown Speed Issue [BLE]

Same problem, really sucks they can’t deal with this. I like the trainer but this spin down issue is driving me crazy!

I had the same issue and the update fixed all the issues connected on BLE.

The problem I’m having is when my neighbour uses his whaoo kicker it knocks my connection out. My heart rate and cadence still work but my power drops to zero. I try to reconnect but the TUO will not register any power while his trainer is on. As soon as his trainer is off I’m gold again.

If I try to connect with ant+ the cadence works but I don’t get a power reading.

I went so see my neighbour and he doesn’t have any issues. He also showed me his phone and it’s not connected to any of my devices.

Got my TUO yesterday, tried to do the spindown calibration, after 45 minutes I gave up, glad to have found this thread, would be nice if ZWIFT would fix the issue, but at least I can get it running properly now, my cadence seems to be good, but will check for updates on the Elite app anyways…

Zwift - PLEASE address this bug/issue that was reported last year.

Ah man, if they don’t even listen to GP lama what chance do I have in getting them to fix the London gradient graph!

Without wishing to spam the thread (but in the hope of bumping the issue) why is what would appear to be a simple fix not getting done? Are we not shouting loud enough?
If this was a thread 1000+ posts long complaining about a feature on (eg) a Kickr, by “legit cyclists”, I bet it would have been done months ago which sort-of illustrates the company’s Achilles heel when it comes to onboarding “new cyclists”.
The Tuo is a great first step into Zwift, but as it’s at the lower end of the scale of trainer hardware, most new users won’t have a single clue about calibration etc and will ultimately end up having an unsatisfactory experience on Zwift.
The likelihood is that a lot of the potential new accounts will ditch the platform rather than hunt for a solution.
Time will tell of course, but the prime reason they want their own hardware is to simplify support, but ■■■■■■ on a bike, they’ll be expected to be A LOT better than this when it eventually happens!

Hi @Nick_Cooke_CCCC have you tried to calibrate using the manufacturer app. That is the preferred way to do it.

I have no idea why Zwift leave calibration as an option in game, it seems to not work more than it does.

If they know it doesn’t work why not just say to use the trainers app to calibrate and be done with it?

1 Like

Hello - yes, that’s how I calibrated mine, but I consider myself to be pretty savvy… just making the point that for a novice it’s confusing, hence the existence of this thread :+1:t2:
What looks like a simple fix would put it to bed

“Fixed an issue with the spindown calibration reporting incorrect speed when set to metric units for JetBlack and Elite trainers.”

Anyone tried this since the last update? The weather’s too good here to be inside at the moment so I haven’t been on…

Yep. Works over direct BLE only (not ANT+ FE-C or BLE via the Companion App). Spin up to ‘37kph’ is on screen but it only requires you to spin up to 33-34kph before asking to coast. The process works well. The change log needed more detail (direct BLE ONLY). Wahoo trainers allow spindown over ANT+ FE-C.

Yep, mine seems to work properly now, over BLE, spin to 37km and then coast, no problem…