ELITE RealTour ANT+ wireless

Thanks, will try your workaround.

I too opened a ticket, and after some back and forth and me insisting that this is not a calibration nor a firmware issue, my ticket was escalated to Level 2 support - which suppose to get back to me once they have some new information.

Removed Personal info

1 Like

Thanks. Will try.

Removed Personal info

I have exactly the same problem. I have been using Zwift earlier with my trainer Elite RealTour Ant+ wireless and it has worked as it should but not anymore!
So dissapointed because I thought my trainer was broken.
The problem I have is that the pairing is taking very long time and when it is connected and I can se that the powermeter is working but when I get beck to Watopia the trainer is not responding and my avatar is not moving.

Thanks, I’m having the same issue and I’ll try your workaround. Is it stable at your setup?

Hey i had the same problem!

Here is my solution:

Thanks
David

Hi Shay,
I have the same problem… :thinking: Did you find a solution to the problem?

No. I gave up. I wrote to Zwift many times but all I got was mostly ‘recorded messages’ which were of no help.

‫בתאריך יום א׳, 5 בינו׳ 2020 ב-19:02 מאת ‪Geir T via Zwift Forums‬‏ <‪gozwift@discoursemail.com‬‏>:‬

I tried Peter_Froschl’s solution and this worked for me; Avatar moving, speed and power properly showing on my desktop (RPM only showing in the Zwift Companion app) and resistance on my trainer being controlled according to the %'s in Watopia. Thanks Peter_Froschl !!

What about when doing an ERG workout?

I’ve not tried this (if this was a question to me :wink: )

Unfortunately the solution does not seem to work anymore. Had issues (redo it sometime) last 2 sessions getting it to work and today it did not work anymore (tried 5 times and then gave up) :frowning: Weeird things is indeed, as written above, that in pairing screen, wattage,etc reacts normally on how hard you push … I’ll look into Davids solution also. When someone knnows more about this I’d be interested!!!

Hi all. I have the same issue since November and finally got a response from the guys at Zwift to say that it is because my older Turbomuin is Ant + but not the FEC and therefore the latest update doesn’t support. I am going to try again tonight as I just down loaded another update. It’s a real shame for me as buying another turbo is out of the question.

Yes. Unfortunately it seems that in these old trainers Elite used a proprietary trainer protocol over ANT+ (as oppose to AN±FE-C) and although Zwift in the past wrote the code to support it - in recent updates, they discarded them.

‫בתאריך יום א׳, 29 במרץ 2020 ב-18:05 מאת ‪Alun via Zwift Forums‬‏ <‪gozwift@discoursemail.com‬‏>:‬

Hi everyone. I just made a breakthrough. There are old Elite forums online and for some of the older trainers there are updates to FEC available. If you create an elite account and then follow the route to updates there are specific downloads for each one. Look at the white sticker on your turbo under the front legs. If it says that it accepts updates then you can download and follow the .exe file prompts. I can now use Zwift again on my trainer and could not since November. I was disappointed Zwift changed the support for my trainer as I use it linked to training peaks almost every day until this happened. But to be fair to them they communicated to me well throughout. Good luck everyone and stay healthy during these difficult times.

These are trainers which dont allow firmware updates

Hi,

I have the same problem. It is so frustrating. The workarounds does not work for me :frowning: