ELITE RealTour ANT+ wireless

Hi,
A question to all Zwift users using ELITE RealTour ANT+ wireless trainer (not the MisouroB+ version).
Are you able to connect and use it successfuly with Zwift?
It used to work fine about 2-3 months ago, but this week I discovered that it’s not.
I can pair and discover it in the pairing screen. I can even see the watts changing as I ride it, but once I move out the pairing screen and start riding - the watts freezes and the avatar moves according to the last watt it read in the pairing screen.
Anyone else experiencing such an issue?
Thanks

Hi I have exactly the same issue on a Elite Turbo Muin :frowning: pairing Works and Watts does Change but once I Start the ride the Watts are Frozen to the first Value.

1 Like

Did you Pair the powersource as well as controllable as the FE-C option?

Yes I paired both. I also tried multiple Times to repair and the pairing Works but once I was in watopia the first Watt Value was Frozen.

do you have a screen shot of the paring screen?

I think we need to open a support ticket for this as this “broke” in one of the recent updates and Zwift claim they support RealTour Ant+

Exactly my symptom.

These are not (at least the RealTour ANT+ trainer) FE-C trainers.
Zwift must have developed a special interface for them to work as I guess they use Elite’s propriety ANT+.

Zwift does support ANT+, the ANT+ profile is a standard profile that trainers use, so if the trainer is ANT+ then it will work, that is what is nice about standard protocols .

ANT+ recently introduced the FE-C profile specifically for smart trainers.

1 Like

thanks, if you click on “Trennen” under “Steuerbar” what other options do you have for the trainer?

Hmm no other options I Can disconnect and re Connect but I See no possible other options.

1 Like

This is not the case. ANT+ is the protocol. Within Ant+ one can “speak” many languages… ANT-FE-C is the standard established for speaking with trainers using the same ‘language’ under ANT+.

Supporting only ANT+ means that you support the protocol, however each company (and indeed this was the case in the old days) had their proprietary dialect within this protocol. Zwift and other companies developed support per each trainer. Now a days they usually only support FE-C (and FTMS in BT).

This use to be the case way back when ANT started.

So I tend to disagree, the reason I say that is you can develop your own trainer using the standard ANT+ FE-C protocol and zwift will work with it. I have tested this.

How to Open a Support Ticket ? I think this broke in the Last Updates and they want to fix it. It Works on the pairing Screen :slight_smile:

https://support.zwift.com/contact/contact-us-HJH8N4RNQ

‫deleted Personal Information

I too have a similar issue. Just started a 7 day trial with a Realtour ANT+ which isn’t Firmware upgradeable and uses Elite’s private Ant+ protocol. On one occasion I got the Watts issue you mention, on the other occasion my Avatar wouldn’t even start pedalling. Hopefully Zwift will fix this issue.

Thanks. I will open a support ticket today. I hope Zwift can address this issue.

I opened a support Ticket as well already a few days ago but got only general requests back. BUT I found a workaround which enables me to use zwift even with the bug but also shows that it is not a problem with my setup, calibration or Firmware Version :slight_smile:

(1) Start Zwift
(2) Pairing Page opens like always
(3) Trainer is found and selected as Power resource
(4) Disconnect Trainer and connect Trainer as a speed sensor Trainer (I took anyone from the elite Trainers)
(5) Enter the game
(6) Enter the menu again and open the pairing page from the menu
(7) Now zwift connects automatically the trainer again as power resource and displays that it as disconnected the speed sensor trainer.
(8) Back to the game >>> Now it works :slight_smile:

Hope that helps others as well to overcome this little bug. I think it shows that something is going wrong, with the normal procedure but when you repair somehow later it works.

It is a bug in the game itself and not the setup is broken. At least on my side :slight_smile:

Peter

1 Like

@Peter_Froschl.

Try this and see if it also work.

  1. Start Zwift
  2. unpair everything
  3. select just watch
  4. enter menu open the pairing page from the menu
  5. Pair trainer and all sensors
  6. back to game

Make sure you are always on the latest Zwift version.