Elite RealAxiom Ant+ trainer wont connect to Zwift

Hi guys n’ girls


My Elite trainer has worked flawlessly until I updated the stick to the FE-C protocol. I’m now in a situation were my trainer “kind of connects” to Zwift, but behaves as a dumb trainer on no resistance. When I say “kind og connects”, its because Zwift finds the trainer via the Ant+ stick, but do not control it. The red light on my trainer keeps blinking although Zwift has taken control. The trainer connects properly is towards TrainerRoad and Elites own software, so I cant figure out whats the problem when connecting to Zwift. I’ve uninstalled and reinstalled Zwift, but the issue still persists.


Any help, please! Getting desperate :wink:

You mentioned updating the stick to FE-C. Are we talking about the trainer or the USB ANT+ dongle? I’ve never heard of updating a dongle, so I’m assuming the trainer, but let us know if you meant something else.

The first thing I’d recommend is checking your trainer resistance setting under the in-game Settings menu. The slider should be either towards the middle or further to the right.

Also, make sure you’re not running TrainerRoad or the Elite app at the same time as Zwift. If either one is open, it could be maintaining control of the trainer. I don’t think that’s the problem in this case, but I wanted to mention it.

If neither of those solves it and your trainer can connect over Bluetooth, you may want to try that insetead to rule this out as being an ANT+ issue.

Hi Jason, and thanks for the quick reply!

Elite said something on their website about trainers with upgradeable USB sticks / dongles, but it might be that its the trainer itself that gets the upgrade trough the dongle…


I’m running Zwift, and Zwift only, but it seems like the program is unable to control the trainer even though it pops up in the “controlable trainer”-field. The red light on the trainer does not go solid as it used to, but does so in TrainerRoad. This confuses me big time, and I fell like trying to repair it with a sledgehammer! That probably wont fix the problem, but you know… Frustrated!!!

It can not connect via bluetooth, so I need to find the solution as it is. The slider on trainer difficulty is put towards Max.


Are there any way to restore the trainer to “pre-FE-C” upgrade?


We don’t know anything about rolling back the upgrade, as that’d be more of an Elite question, but I can think of at least a couple more steps that might make a difference on our end.

Try deleting your prefs.xml file in your Documents\Zwift folder. This will reset your preferences, so if there’s any old data Zwift is remembering about your trainer, this will clear it.

If that also doesn’t work, see if any of the other options you can pair to under the Controllable Trainer menu give resistance. i.e. You may see other options like “Elite RealAxiom.”