Elite Direto Not Changing Resistance


(Brangerud Sportsklubb) #62

I have a Direto trainer. PC, windows 10, Ant+ and Zwift.

Did work well the first week or so. But then the resistance all of a sudden just disappeared. Have tried all kinds of troubleshooting, no luck. Yes have read the Ant+ article, but to no use or help.

Any ideas anyone?

Best regards Stig Helge


(Vincent) #63

Hey @jonasm @Brangerud_Sportsklub are you both in workout mode or free ride? And what is your Trainer Difficulty set as?

@Brangerud_Sportsklub do you have any other app or device that could connect to your Direto? If so, can you try unpairing your trainer from every other device besides Zwift and then see if you run into the same resistance issues?


(Jonas Meersschaert) #64

I was riding in free mode, The trainer difficulty was set to maximum.


(Luc Heijnen) #65

Just to be sure, have you tried unpairing the Direto and then repairing? Make sure that you pair with the controllable FE-C option. Maybe worth checking, it works fine here (no trouble with the Direto at all the last few months)


(Brangerud Sportsklubb) #66

Thanks! Trainer was broken, now new one!


(Brangerud Sportsklubb) #67

Thanks, trainer was broken, now new one!


(Dirk van Ree) #68

I have the same issue. Tried it connected to apple tv and on a windows 10 laptop in combination with companion app on iphone xs. Both no big changes in power. It seems to work in workoumode (erg) but not in free ride


(Whitman Schofield) #69

I have the same issue Direto connected to mac OS with bluetooth not changing resistance. In fact it seemed to almost randomly for sort periods ramp up resistance and then no change at all


(Devin Knickerbocker2522) #70

I’d recommend trying explicitly to pair your trainer with your computer using an Ant+ dongle. I had the same issues with Elite Direto trainer resistance after one of the updates and nothing i did could fix it. As soon as I switched to Ant+ for the connection, it went back to normal.

But, be careful to select the correct trainer profile and connection type when pairing your devices. There are, let’s just say, more options than you might expect.


(Anthony Barron) #71

I have solved this issue - at least for myself - it is all about the ‘Controllable’ connection in the Pairing screen in Zwift.

My Elite Direto can connect to Zwift (the Controllable panel) in two ways:

  1. Elite RealTrainer [ID] <-- INCORRECT
  2. ELITE FE-C[ID] <-- CORRECT

BOTH of the above are ant+ options. See screenshot.

After a ride, with resistance working correctly, if I leave everything on and go back into Zwift I risk the trainer re-connecting to the wrong one.

The first picture is the correct configuration, the second is the choice that the trainer puts out and the last picture is the incorrect configuration which will not give you a variable resistance.

If you connect to the wrong option in the Controllable panel, just hit ‘Unpair’ and select the correct one.

If you do not see the correct option, turn off all other Bluetooth and ant+ devices until you can see the option begining: ‘ELITE FE…’

Good luck.


Direto not providing resistance
(Steven ) #72

That’s pretty much what I said in this post on 12 November (although not with all the pictures).
As I mentioned before, the key is to wake the trainer up (pedalling to switch it on) before starting Zwift and reaching the pairing screen. Then Zwift will correctly connect to the last trainer used. However, if you only wake it up once you have started Zwift app and on the pairing screen, it will pair with the “RealTrainer” option.

This is great for the Ant+ options on PC, but I’m not sure this is what others are facing with other platforms or via Bluetooth.


(Marcelo Almeida) #73

I am having the same problem.
Brand new ELITE DIRETO (1st use). MacBook Pro with ANT+ Dongle and extension cable. So dongle is very close to Trainer. Using Garmin Heart Rate Monitor as well. Not using the companion software on the cellphone.

Get no resistance feedback. Tried resetting the trainer. Trined restarting zwift software. Tried selecting ELITE FE-C in the controllable option. Still no resistance feedback.

What can I do Zwift ?


(David Esteban) #74

I have the same problem. I’ve been using Direto for months and it has never failed so far. Now he has no resistance. Connected via ANT +

Is it a problem with the Zwift software, Direto?


(Matias Garcia Fleer) #75

Same problem here. Direto does not work in ERG-Mode anymore, maybe a problem with FE-C protocol? Tried Ant+ Dongle/Laptop, Wahoo Elemnt Bolt and Samsung S7 as Headunit (via programs Zwift & Trainerroad). Nothing could get the Direto to adjust the resistance itself. Manual/Incline mode works.


(David Esteban) #76

Hello Matias, I have solved it by configuring the wheel size on my Wahoo device in automatic mode.


(Dale Cornette) #77

My Direto just started dropping out tonight. Used it last week and weeks prior with no issue. Tonight I’ve had 3 dropouts after maybe 10 minutes of riding. Power cycling the trainer worked a couple times, had to restart Zwift once. Zwift reads power off the trainer, but won’t control resistance. This is infuriating right after the price to use the app goes up…

The only thing I changed from previous rides is going from power pedals to normal pedals, so I lost the cadence sensor.

My setup is a PC with ANT dongle on an extension cable. Dongle is inches from the trainer, I never have sensor dropout issues.


(Peter Crimmin) #78

Same problem.

Direto Trainer. I used for last 15 months without problem. Set up is:
Direto, Macbook Air, and Ant + sensor

#1 - Tour de Zwift - Stage 2 NYC - no resistance controls. After the stage, re-paired the trainer and did free ride on the course and resistance worked. Tested ERG mode and it works.

#2 - Today - TdZ Stage 3 London - no resistance. After the stage, no resistance.

Suddenly I have sympathy for everyone who has been having this problem for months.


(Dale Cornette) #79

Welp, seems my removal of the power pedals was the culprit in my case. I have a cadence sensor on the bike, but no magnet, so it was linking up with Zwift and giving a false cadence reading somehow. When that false reading stopped, Zwift killed the trainer control for some reason. I unlinked from the cadence sensor and the trainer control came back immediately and never dropped again.


(Nico) #80

I’m having the opposite type of problem: after a period where I was getting no more resistance response and was spinning out, I get extremely high and pulsating resistance in Zwift. On a flat road, the resistance pulses up to what I would say is a 15% climb and back down, every 2 seconds. I have resorted to disconnecting the trainer from Zwift and switching on my Wahoo Elemnt computer (I usually keep it off during zwifting to avoid interference, putting the trainer in resistance mode. Then the trainer works fine again.

Very frustrating and makes things a lot less fun!


(Steve Bedder) #81

After an update to Zwift last week I had no resistance using my Elite Qubo Digital Smart B+ trainer. Zwift is installed on a Windows 10 Pro laptop and connected by Ant+ using the FE-C option.

On the odd occasion I’ve had this issue before I’ve unlinked and re-linked the trainer to Zwift and its all sorted, but this time I’ve had no resistance since the update even after several un link and relink.

Then today, 15 miles into a ride where I’d had no resistance and been doing 440 watts up an 8% climb in a high gear, I all of a sudden had so much resistance I could only manage 50 watts on the flat in a low gear - something similar to the previous poster.

Please can you prioritise a fix for this Zwift as what’s he point of a training app that doesn’t actually give you a training experience