Elite Direto Not Changing Resistance


(Vincent W.) #1

This was a popular topic that sparked a lot of discussion, so we’ve decided to bring it over to our new forums! Any duplicate topics created will be merged with this one. Enjoy the discussion and Ride On.

Hi,

Just returned to zwift after a summer break. I did a quick ride last night but noticed the change in inclines weren’t registering with my Direto, the resistance wasn’t changing. It worked fine a few months back. I’m using an iPad. It seems to pair ok, everything else works. Am I missing something obvious?

Cheers,

Simon.


(Erik L) #2

Me too!

Using AppleTv and connectiong via Bluetooth.
No resistance at all.

Erg works in workoutmode.


(Matthew Whitwell) #3

Same here. Thought it was fixed but had it again today. Specifically i think it’s related to kom course in innsbruck. As I’ve ridden other routes and it’s fine.


(Matthew Whitwell) #4

I first raised this two months ago. What’s going on zwift?


(Luc Heijnen) #5

Bluetooth just doesn’t give a solid connection with the Direto (although recent iPhone/iPad do, so i’m guessing the Direto has the latest bluetooth version and is not compatibel with older material).
ANT+ works fine (using a 2012 macbook pro). Even so, I ran into some rare cases of ERG-error after Zwift software updates. Solution every time was to unpair my Direto in Zwift, search for compatible trainers and repair the Direto.


(Matz Binder) #6

same issue here and it appears to be only on the KOM segment. Wattage seems to hover around that particular value I had when entering the KOM but do not further change neither when increasing cadence nor changing gears.
I don‘t even think it‘s a Direto issue since I experienced the same behaviour with an old Vortex Smart.

Cheers, Matz


(Vincent W.) #7

There have been a lot of reports for Direto resistance issues as you can imagine but we’re hoping in a near update most of these issues are fixed. We’ll be checking back for reports.

It seems to mostly be an iOS Bluetooth issue.


(Matthew Whitwell) #8

Hi has this been checked and tested yet? My last ride. Week ago in Innsbruck was definitely a problem.


(Erik Schumacher) #9

There have been a lot of reports for Direto resistance issues as you can imagine but we’re hoping in a near update most of these issues are fixed. We’ll be checking back for reports.

It seems to mostly be an iOS Bluetooth issue.

Interesting, I was not aware that it is such a common problem.

I got the same setup (Direto + Apple TV) and I had some issues too. Most of the time I could solve them by a restart of the Direto and/or Zwift. Meanwhile I am used to these issues, but nevertheless I am looking forward to see them have been fixed in future Zwift updates :grinning:


(Tom Schultz [Krt]) #10

My wife and I have been having this issue off/on ever since the Alpe du Zwift update. Simply unplugging the Direto and plugging it back in while riding has been the “band aid” for us. We both use iPads.

For the past month or so, we have noticed losing resistance whenever we enter an event or pause a workout. Very frustrating to realize you are getting no resistance after a race starts… unplugging means losing the group.

Hope this issue is resolved soon…


(Matz Binder) #11

Just as a follow-up:
I had Elite support looking into my issues with wattage drops which I thought was related to Zwift, but it turned out to be a bad calibration.
As printed in the manual, I tensioned the belt to get a calibration that exactly matches the offset you can find on the sticker beneath the trainer.
Haven’t had any issues ever since :slight_smile:

Cheers, Matz


(Erik Schumacher) #12

Mhm interesting, I had to replace my belt a while ago, my default value was 6600, but now it is 6610, because it was impossible to adjust the old value. I had a conversion with the Elite support team about that and they told me that it is OK to stay at 6610. Well, I think I have to take a closer look into calibration again.

Thanks for the hint Matz.


(Matz Binder) #13

well, my calibration was 6222 and the offset was 6229. Support advised me to tune in to exactly reach 6229. In theory you should be able to calibrate to the offset value even after replacing the belt and pulley.
Before I touched base with the supporting team I did a lazy re-tension to 6225 which I considered to be close enough to the factory setting. Baseline here is to get as close to the offset as possible.

Cheers, Matz


(Erik Schumacher) #14

In my case there are two problems, the screw is too short to unscrew it more and if I reduce the tension the belt starts slipping. But nevertheless I am gonna check my calibration on the weekend, maybe my belt has stretched a bit in the meantime and I can adjust the trainer better.


(Matz Binder) #15

Don’t forget to give it a good warm-up prior to entering the spin-down. Calibrating the cold Direto spits out some odd numbers :wink: But I bet you did that.

Cheers, Matz


(Michael Foradas) #16

I have also seen controllable resistance drop out when my Direto trainer is being controlled by Zwift running via Bluetooth on Apple TV.


(Leonardo Nascimento) #17

Hi Vincent,

Just wanna report here same behavior both when controlling the Direto through Bluetooth using the companion app as well as directly from Zwift using my Pixel 2 phone.

Ant+ works perfectly from the PC, though.

My Garmin reports the Direto having firmware 4.70. My Pixel 2 has all updates and my PC is Win 10 with all updates as well.

Let me know if you need any extra information to help pinpoint the problem. I am also available to run any debug sessions if you like.

Cheers.


(Anthony Von Barron) #18

I have elite direto with Android and ant plus.l - not Bluetooth. No resistance changes at all. Rode NYC skyway today, nothing. I’m just grinding it out in my 53 11 at 270 watts, can’t get any more resistance.

Didn’t used to be this way. Please please fix!!!


(Troy Ketela) #20

For the first time, I ran into this issue with my Direto. The difference for me to my prior rides is that I was using a different combination of bluetooth widgets and started using the companion app. I never ran into the issue before I started using the companion app and running the bluetooth connection for one or more widgets through it.


(Marco Stirrandro) #21

I have the Elite Drivo I but have just experienced behaviour like this riding the Innsbruck course a couple of hours ago. Resistance was all over the show, almost like the trainer was receiving instructions for a different course. At 10% it could be an easy spin and on the flat a real push, or vice versa, no obvious pattern.

Connecting via Ant+ from Window 10 Laptop and Companion app running on Android.

These aren’t the only issues I’ve had either. I’ve had resistance staying completely static on Watopia and NYC but was able to sort this out by repairing sensors one at a time.

I’ve tested my Drivo with a few different apps and only Zwift appears to present any issues. Hope you guys can resolve this as I’ve only just joined and enjoy the innovative experience but this power issue will need to be fixed to keep me on board.

Thanks

Mark